activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From delphz <delphine.zieg...@capgemini.com>
Subject Re: Timeout and Failover on a queue
Date Fri, 19 Oct 2007 12:37:40 GMT

I set the maxReconnectAttempts to 1 and it is trying to reconnect endlessly.
And it can't connect to the B servers, even if they are up.


Eduardo Corral wrote:
> 
> Hi Delphine
> 
> Have you checked the log files? Maybe the clients (A1, A2,...) do follow 
> the timeout parameter, but they are trying to reconnect endlessly...
> 
> http://activemq.apache.org/failover-transport-reference.html
> 
> With failover, you may also configure how long between retries and how 
> many of them.
> 
> Best regards,
> Eduardo Corral
> 
> delphz escribió:
>> Hello,
>>
>> I have some servers A1, A2, AN, ... that send messages on a queue on
>> servers
>> B1 ans B2. I configured my A servers to connect with the following URI :
>> failover:(tcp://B1:61616,tcpB2:62626). But when activemq is stopped on
>> both
>> B1 and B2, my servers A wait a long time before deciding that B1 and B2
>> are
>> down. So I test to add a timeout.
>>
>> If I configure my A servers with : tcp://B1:61616?connectionTimeout=1000,
>> I
>> have no problem. But if I configured with the following :
>> failover:(tcp://B1:61616?connectionTimeout=1000,tcp://B2:62626?connectionTimeout=1000),
>> it doesn't work. I tried lot of things :
>> - set connectionTimeout after the ) :
>> failover:(B1,B2)?connectionTimeout=1000
>> - set closeTimeout on my ConnectionFactory
>> - set wireFormat.maxInactivityDuration
>> - ...
>>
>> I can't get it work.
>>
>> Could you tell me how to configure it ?
>>
>> Thanks !!
>>
>> Delphine
>>   
> 
> 

-- 
View this message in context: http://www.nabble.com/Timeout-and-Failover-on-a-queue-tf4652630s2354.html#a13293655
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message