activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ozomozo <ozom...@yahoo.com>
Subject Re: XMPP/Jabber and ActiveMQ
Date Wed, 17 Oct 2007 20:38:23 GMT


These are my JMX specs:

    <managementContext>
       <managementContext connectorPort="2099"
jmxDomainName="org.apache.activemq"/>
    </managementContext>

Is there some configuration im missing ??




ozomozo wrote:
> 
> Ive edited the activemq.xml file to add the XMPP transport:
> 
> <broker xmlns="http://activemq.org/config/1.0">
>     <transportConnectors>
>        <transportConnector name="openwire" uri="tcp://localhost:61616"
> discoveryUri="multicast://default"/>
>        <transportConnector name="stomp"    uri="stomp://localhost:61613"/>
>        <transportConnector name="xmpp"     uri="xmpp://localhost:61222"/>
>     </transportConnectors>
>   </broker>
> 
> I tried to restart activemq and i get this error:
> ___________________________________________________________-
> 2007-10-16 14:17:01,904 [erSimpleAppMain] INFO  TransportConnector            
> - Connector stomp Started
> 2007-10-16 14:17:01,906 [erSimpleAppMain] ERROR BrokerService                 
> - Failed to start ActiveMQ JMS Message Broker. Reason:
> java.io.IOException: Transport Connector could not be registered in JMX:
> Transport scheme NOT recognized: [xmpp]
> java.io.IOException: Transport Connector could not be registered in JMX:
> Transport scheme NOT recognized: [xmpp]
>         at
> org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:25)
>         at
> org.apache.activemq.broker.BrokerService.registerConnectorMBean(BrokerService.java:1079)
>         at
> org.apache.activemq.broker.BrokerService.startTransportConnector(BrokerService.java:1517)
>         at
> org.apache.activemq.broker.BrokerService.startAllConnectors(BrokerService.java:1471)
>         at
> org.apache.activemq.broker.BrokerService.start(BrokerService.java:402)
> ..........................................and more
> 
> Caused by: java.io.IOException: Transport scheme NOT recognized: [xmpp]
>         at
> org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:25)
>         at
> org.apache.activemq.transport.TransportFactory.findTransportFactory(TransportFactory.java:171)
> ..........................................and more
> 
> Caused by: java.io.IOException: Could not find factory class for resource:
> META-INF/services/org/apache/activemq/transport/xmpp
>         at
> org.apache.activemq.util.FactoryFinder.doFindFactoryProperies(FactoryFinder.java:90)
> .................. and more
> 
> ____________________________________________________________________
> 
> Ive added these additional jar files as suggested in an earlier blog:
> sjsxp.jar
> stax-1.1.1-dev.jar
> activation-1.1.jar
> jaxb-impl-2.0.2.jar
> jsr173_api-1.0.jar
> jaxb-api.jar
> 
> Any reason why I get these errors.  I want to be able to create/access the
> Spark jabber client and eventually be able to 'produce' messages based on
> certain 'chat' topics.
> 
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/XMPP-Jabber-and-ActiveMQ-tf4637156s2354.html#a13262426
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message