activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From thomfost <THOMF...@uk.ibm.com>
Subject Re: stomp/activemq error occuring, help!?!
Date Mon, 15 Oct 2007 15:32:21 GMT

Some extra points i would like to make to my previous post.

-I am using the PHP stomp client with SCA for PHP.
- After i enabled the debug logging I saw that every time activemq adds a
consumer via the stomp client, the log shows these lines (obvioulsy with
different time and port number):
2007-10-15 11:29:02,982 [/127.0.0.1:2121] TRACE TcpTransport  - TCP consumer
thread starting
2007-10-15 11:29:02,982 [/127.0.0.1:2121] DEBUG TransportConnection -
Setting up new connection: /127.0.0.1:2121

However when my error does occur, in readFrame() in the Stomp.php file at
the line...

$rc = socket_recv($this->socket,$b,1,0);

... the code stops executing and i get no response from activemq
acknowledging the connection (i.e. the CONNECTED frame). But looking at the
activemq log, the following lines still appear which suggest that activemq
acknowledged or at least recieved the original CONNECT frame sent by the
client:

007-10-15 11:29:02,982 [/127.0.0.1:2121] TRACE TcpTransport  - TCP consumer
thread starting
2007-10-15 11:29:02,982 [/127.0.0.1:2121] DEBUG TransportConnection -
Setting up new connection: /127.0.0.1:2121

Any ideas on what is happening?? Is it an error with activemq or the client?
What I don't get is why 75% of the time everthing works fine with no errors.
Please, any help would be great, its driving me mad!

Cheers.




thomfost wrote:
> 
> Hi,
> 
> I am using ActiveMQ with the stomp client for PHP
> (https://svn.codehaus.org/stomp/trunk/php/Stomp.php). Now the majority of
> the time everything works fine, however every so often, something is
> happening which stops the code from executing further. I eventually found
> that the error occurs in the Stomp.php file in the readFrame() method at
> this line:
> 
> $rc = socket_recv($this->socket,$b,1,0);
> 
> Does anyone know why an error occurs here? Could there something going
> wrong in ActiveMQ? When the code does work successfully, $rc is 1.
> Sorry if this is all a bit vague, but im relatively new to all this and im
> not familiar with the ins and outs so if anyone has any help or can shed
> some light onto what is happening (or should be happening) then it would
> be much appreciated.
> 
> Many thanks,
> Tom
> 

-- 
View this message in context: http://www.nabble.com/stomp-activemq-error-occuring%2C-help%21-%21-tf4605839s2354.html#a13214222
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message