activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From akuhtz <andreas.ku...@siemens.com>
Subject Re: XMPP error in ActiveMQ 5 (FUSE Message Broker 5.0.0.2)
Date Wed, 03 Oct 2007 13:15:12 GMT

I had the same problem. Download the sjsxp.jar from somewhere and add to the
classpath (I saved it to the /lib directory). 
see also:  http://forums.java.net/jive/thread.jspa?messageID=117971
http://forums.java.net/jive/thread.jspa?messageID=117971 

After that it worked =)


Fintan Bolton wrote:
> 
> I'm testing the version of ActiveMQ embedded in FUSE Message Broker
> 5.0.0.2, trying to get the XMPP protocol to work.
> 
> After installing the binary distribution on Windows, I ran the ActiveMQ
> broker with the following command:
> 
>> activemq
> 
> With the default settings.  The broker appears to start up without any
> errors and it tells me that the XMPP transport has started.  E.g. it logs
> the following to the screen:
> 
> INFO  TransportServerThreadSupport   - Listening for connections at:
> xmpp://fboltond820:61222
> INFO  TransportConnector             - Connector xmpp Started
> 
> But when I try to connect to the XMPP port (localhost:61222) using a Spark
> 2.5.7 client, I see the following error in the ActiveMQ broker window:
> 
> -----snip-----
> Exception in thread "ActiveMQ Transport: tcp:///127.0.0.1:2062" Exception
> in th
> ead "ActiveMQ Transport Initiator: /127.0.0.1:2062"
> javax.xml.stream.FactoryCon
> igurationError: Provider com.bea.xml.stream.MXParserFactory not found
>         at
> javax.xml.stream.FactoryFinder.newInstance(FactoryFinder.java:72)
>         at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:176)
>         at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:92)
>         at
> javax.xml.stream.XMLInputFactory.newInstance(XMLInputFactory.java:13
> )
>         at
> org.apache.activemq.transport.xmpp.XmppTransport.doRun(XmppTransport
> java:143)
>         at
> org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java
> 176)
>         at java.lang.Thread.run(Thread.java:595)
> javax.xml.stream.FactoryConfigurationError: Provider
> com.bea.xml.stream.XMLOutp
> tFactoryBase not found
>         at
> javax.xml.stream.FactoryFinder.newInstance(FactoryFinder.java:72)
>         at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:176)
>         at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:92)
>         at
> javax.xml.stream.XMLOutputFactory.newInstance(XMLOutputFactory.java:
> 8)
>         at
> org.apache.activemq.transport.xmpp.XmppTransport.writeOpenStream(Xmp
> Transport.java:244)
> -----snip-----
> 
> It looks like there is a missing dependency here (e.g. the class,
> com.bea.xml.stream.MXParserFactory).  But I would have expected that all
> of the requisite classes would be included in the package.
> 
> Cheers,
> Fintan
> 

-- 
View this message in context: http://www.nabble.com/XMPP-error-in-ActiveMQ-5-%28FUSE-Message-Broker-5.0.0.2%29-tf4554585s2354.html#a13018702
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message