activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tim.b...@sensis.com>
Subject Re: Multicast Discovery connection
Date Fri, 19 Oct 2007 19:20:34 GMT
You can see what options are available to you on the configuration page
http://activemq.apache.org/cms/configuring.html

As you can see the only protocol option right now is TCP.

Regards
Tim.


http://activemq.apache.org/cms/configuring.html

On Fri, 2007-10-19 at 12:15 -0700, appi03 wrote:
> well that will do it. 
> 
> Okay i have to ask this question? where can i find out what features are
> supported by the cpp client. 
> 
> 
> 
> tabish121 wrote:
> > 
> > The CPP client doesn't support discovery.
> > 
> > Regards
> > Tim
> > 
> > On Fri, 2007-10-19 at 11:10 -0700, appi03 wrote:
> >> 
> >> I am trying to use the multicast discovery protocol and having some
> >> trouble
> >> with it. I think i have the broker configuration down.
> >> 
> >> Client 1 (Producer) -> Broker 1
> >> <transportConnector uri="tcp://localhost:61616"
> >> discoveryUri="multicast://prod1"/> 
> >> 
> >> <networkConnector name="producer"  uri="multicast://prod1" /> 
> >> 
> >> 
> >> Client 2 (Consumer) -> Broker 2
> >> <transportConnector uri="tcp://localhost:61616"
> >> discoveryUri="multicast://cons1"/> 
> >> 
> >> <networkConnector name="producer"  uri="multicast://cons1" /> 
> >> 
> >> 
> >> 
> >> But I am not sure how to configure the client side. this is what I have.
> >> 
> >> Client 1
> >>  std::string brokerURI =
> >>         "tcp://localhost:61616"
> >> 	"discovery:multicast://prod1"
> >>         "&transport.useAsyncSend=true"; 
> >> 
> >> ActiveMQConnectionFactory( brokerURI );
> >> 
> >> 
> >> Client 2:
> >>  std::string brokerURI =
> >>         "tcp://localhost:61616"
> >> 	"discovery:multicast://cons1"; 
> >> 
> >> ActiveMQConnectionFactory( brokerURI );
> >> 
> >> So when I start the brokers, I can see the connection being established
> >> between two brokers. But the client 2 never sees any messages produced by
> >> cllient 1.
> >> 
> >> I am sure it's the way I am configuring it. I can't seem to find any
> >> documentation on how to configure the connection factory while using
> >> discovery. 
> >> 
> >> If anyone has any idea please let me know.
> >> 
> >> thanks,
> >> arpit
> > 
> > 
> 

Mime
View raw message