activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glen Mazza <glen.ma...@verizon.net>
Subject Re: Couldn't get jdbcPersistenceAdapter working
Date Sun, 07 Oct 2007 00:03:02 GMT
Am Freitag, den 05.10.2007, 02:20 -0700 schrieb Yuen-Chi Lian:

> Hi all,
> 
> This is strange. I have poked around Google and the mailing list, but
> couldn't really find the exact solution to my problem. 
> 
> I am trying to enable jdbc persistence and I am getting the error below:
> 
> to start ActiveMQ JMS Message Broker. Reason: java.io.IOException: Failed to
> get last broker message id:
> com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Table
> 'activemq.activemq_acks' doesn't exist

Normally the reason for an exception like this is rather
unambiguous--the database driver cannot find the database table
"activemq_acks" within the activemq schema, either (a) because it does
not exist or (b) the username/password you are supplying for that
database does not have access rights to that table.  Can you use an
external query tool to make sure the table exists (pay attention to case
sensitivity), and that the username you have accessing it can select
from that table?  Also, how many mysql installations do you have on your
machine?  That could be another problem.

HTH,
Glen


> 1. I have MySQL JDBC driver in my classpath,
> mysql-connector-java-5.0.7-bin.jar
> 2. I have tried making things "clean" by removing my
> ${activemq.home}/activemq-data
> 3. I have tried uncommenting the mysql-ds in the default config as well as
> using my own simple one:
> 



Mime
View raw message