activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dantelope <dantel...@gmail.com>
Subject Re: Virtual Topic not working as expected - defect, or misunderstanding?
Date Tue, 25 Sep 2007 15:11:51 GMT

Hi, James - thanks for the quick reply.

I had not started it in persistent mode and I was not statically defining
the consumer queue.  However, upon doing that the same results apply.

I *should* be able to start this broker, send messages to the topic, bring
down the broker, bring up the broker, and retrieve the messages.

Does it matter how the broker is brought down?  I'm doing it as harshly as I
can to simulate removal of power...


Broker Configuration Snippet:
------------------------------------------------------------------------------------------
<destinations>
  <topic physicalName="VirtualTopic.FOO"/>
  <queue physicalName="Consumer.dantelope.VirtualTopic.FOO"/>
</destinations>

Producer Snippet:
------------------------------------------------------------------------------------------
ConnectionFactory factory = new ActiveMQConnectionFactory(
"tcp://localhost:61616" );
Connection conn = factory.createConnection();
Session session = conn.createSession( false, Session.CLIENT_ACKNOWLEDGE );
TextMessage msg = session.createTextMessage( "Hello, world!" );
MessageProducer prod = session.createProducer( new ActiveMQTopic(
"Consumer.dantelope.VirtualTopic.FOO" ) );
prod.setDeliveryMode( DeliveryMode.PERSISTENT );
prod.send( msg );




James.Strachan wrote:
> 
> Are you sending the messages using persistent mode?
> http://activemq.apache.org/what-is-the-difference-between-persistent-and-non-persistent-delivery.html
> 
> If not then its expected behaviour.
> 
> Note that to re-enable the consumer each time you need to start the
> consumer on startup of the broker or add the
> Consumer.A.VirtualTopic.FOO queue to the startup destinations.
> 
> http://activemq.apache.org/configure-startup-destinations.html
> -- 
> James
> -------
> http://macstrac.blogspot.com/
> 
> Open Source SOA
> http://open.iona.com
> 
> 

-- 
View this message in context: http://www.nabble.com/Virtual-Topic-not-working-as-expected---defect%2C-or-misunderstanding--tf4511392s2354.html#a12881785
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message