activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SurajN <nambia...@yahoo.com>
Subject Re: AMQ 4.0.x & MDB Listener not connecting
Date Thu, 13 Sep 2007 11:56:54 GMT

Hi James,

I am also facing the same issue with WAS5 and ActiveMQ4.1.1

This appears to be a local transaction issue in websphere.

This happens when websphere tries to create a new server session by calling
new ServerSession() [com.ibm.ejs.jms.listener.ServerSession]. The
constructor starts a local transaction and then goes into an infinite loop.
I have attached the file ServerSession.java

I have also attached the server trace logs.

Please advise.

Regards,
Suraj



Muzza wrote:
> 
> Hi Guys,
> 
> Could someone take a look at this please ?
> 
> Thanks,
> Steve
> 
> 
> Muzza wrote:
>> 
>> Hi James,
>> 
>> I've managed to look into this problem again and have attached a Word
>> Document with screenshots of the JMX view of this problem. One set of
>> screenshots showing what happens in JMX when I have a message on AMQ and
>> then fire up an MDB in Websphere 5.1. The other set of screenshots then
>> show what happens when I clear down the MDB request queue and start up
>> Websphere.
>> 
>> The difference I've found between the two is that I never get a
>> Subscription when I have a message already on the queue, this is apparent
>> in the screenshots.
>> 
>> Can you take a look and advise please ? 
>> 
>> Thanks,
>> 
>> Steve.
>> 
>> James.Strachan wrote:
>>> 
>>> On 9/4/06, Muzza <stephen.murray@amt-sybex.com> wrote:
>>>>
>>>> Hi James,
>>>>
>>>> I've ran Jconsole and can see that my queue exists and that a
>>>> connection is
>>>> established to the broker.
>>> 
>>> How about looking at the subscriptions to see what its subscribing to
>>> - to check that the subscriptions really are subscribing to the same
>>> name queue?
>>> 
>>> 
>>>> But still when the queue has any sort of
>>>> queuesize the MDB doesn't fire it's onMessage.
>>>>
>>>> Is there any particular screenshot from Jconsole I can send in or is
>>>> there
>>>> any log file from AMQ I can produce ?
>>>>
>>>> When the underlying architecture was changed between 3.2.2 and 4.x
>>>> would
>>>> this have affected the ActiveMQWASInitialContextFactory, which we use
>>>> when
>>>> connecting to AMQ via Websphere ?
>>> 
>>> I don't think so as its purely to workaround some WAS JNDI issues
>>> 
>>> -- 
>>> 
>>> James
>>> -------
>>>  http://radio.weblogs.com/0112098/ http://radio.weblogs.com/0112098/ 
>>> 
>>> 
>> 
>> http://www.nabble.com/file/p6505260/AMQ%2520MDB%2520Not%2520Connecting.zip
>> AMQ MDB Not Connecting.zip 
>> 
> 
> 
http://www.nabble.com/file/p12653379/trace.log trace.log 
http://www.nabble.com/file/p12653379/ServerSession.java ServerSession.java 
-- 
View this message in context: http://www.nabble.com/AMQ-4.0.x---MDB-Listener-not-connecting-tf2179115s2354.html#a12653379
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message