activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From budcurtis <bud.cur...@gmail.com>
Subject Re: XBean Jetty config for ActiveMQ?
Date Tue, 04 Sep 2007 17:21:36 GMT

I ran the activeMQ batch file with ACTIVEMQ_CLASSPATH set to every jar in lib
and lib/option with the same results as reported before.:confused:  I
verified it was being passed in by setting ECHO ON in the batch file.  I
have no idea what it may require in additional jars.  I also tried to get
the SNAPSHOT 5 as you suggested from the Active MQ download page, but that
has alluded me also (I can't see how to download it).

The following shows the first couple line of the exception:
Loading message broker from:
xbean:file:/dev_tools/apache-activemq-4.1.1/conf/rpm_activemq.xml
ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
org.springframework.beans.factory.BeanDefinitionStoreException: Unrecognized
xbean namespace mapping: http://mortbay.com/schemas/jetty/1.0
java.lang.RuntimeException: Failed to execute start task. Reason:
org.springframework.beans.factory.BeanDefinitionStoreException: Unrecognized
xbean namespace mapping: http://mortbay.com/schemas/jetty/1.0
	at
org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:70)
	at
org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:50)
	at
org.apache.activemq.console.command.ShellCommand.runTask(ShellCommand.java:65)



James.Strachan wrote:
> 
> You've probably not got the correct jars on the classpath? e.g. grab a
> 5.0-SNAPSHOT of ActiveMQ, see its activemq.xml and its classpath (the
> jars on the lib directory) and check your classpath against it.
> 
> On 8/31/07, budcurtis <bud.curtis@gmail.com> wrote:
>>
>> I'm trying to include the jetty configuration in the ActiveMQ XBEAN:
>>
>>   <jetty xmlns="http://mortbay.com/schemas/jetty/1.0">
>>     <connectors>
>>       <nioConnector port="8161" />
>>     </connectors>
>>     <handlers>
>>       <webAppContext contextPath="/admin"
>>              resourceBase="${activemq.base}/webapps/admin"
>> logUrlOnStart="true" />
>>     </handlers>
>>   </jetty>
>>
>> but the URL http://mortbay.com/schemas/jetty/1.0 is not available.
>>
>> I get the exception:
>> BeanDefinitionStoreException: Unrecognized xbean namespace mapping:
>> http://mortbay.com/schemas/jetty/1.0
>>
>> Can someone tell what URL to use, or is it basically unavailable and I
>> should try another configuration method.
>> --
>> View this message in context:
>> http://www.nabble.com/XBean-Jetty-config-for-ActiveMQ--tf4362724s2354.html#a12434813
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> -- 
> James
> -------
> http://macstrac.blogspot.com/
> 
> 

-- 
View this message in context: http://www.nabble.com/XBean-Jetty-config-for-ActiveMQ--tf4362724s2354.html#a12482640
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message