activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Snyder" <bruce.sny...@gmail.com>
Subject Re: How to monitor ActiveMQ that run in JBOSS
Date Mon, 27 Aug 2007 02:35:50 GMT
On 8/26/07, ferry97 <vri_97@yahoo.com> wrote:
>
> Hi Bruce,
> If I run ActiveMQ as a standalone, there is no problem to run the
> Web-Console, but in my scenario ActiveMQ is running under JBoss, and I
> didn't see any web server (jetty) running. None is listening in port 8161.
> Or perhaps I miss some setting in Jboss to enable the web-console ?

What build of ActiveMQ 5 are you using?

> I don't know whether it's related, but I always get this error :
>
> 2007-08-24 11:23:24,838 DEBUG
> [org.apache.activemq.broker.jmx.ManagementContext] Failed to create local
> registry
> java.rmi.server.ExportException: Port already in use: 1099; nested exception
> is:
>         java.net.BindException: Address already in use: JVM_Bind

Yeah this is just a debug level error stating that ActiveMQ tried to
start up the MBean server and found that port 1099 was already being
used. When this happens, ActiveMQ usually just uses the MBean server
already running on that port if it can.

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

Apache ActiveMQ - http://activemq.org/
Apache ServiceMix - http://servicemix.org/
Apache Geronimo - http://geronimo.apache.org/
Castor - http://castor.org/

Mime
View raw message