activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mario Siegenthaler" <msiegentha...@inventsoft.ch>
Subject Re: two instances of web amq - one webconsole
Date Tue, 28 Aug 2007 10:00:59 GMT
If the console starts up an own ActiveMQ instance then you most likely
forgot to set -Dwebconsole.type=properties The webconsole supports
multiple types of configuration and the type is specified via a system
property. For every type there's an own spring configuration file
inside the webconsole (f.e. webconsole-properties.xml) and the system
property tells it which one to use.
Else your settings are looking good to me.

Mario

On 8/28/07, den!s <tiger-2214@caramail.com> wrote:
>
>
> Mario Siegenthaler-2 wrote:
> >
> > Only if the two are a master/slave pair (only one running at a time).
> >
>
> This is what i'm using : master/slave with Shared File system.  But I
> realize that my main problem is (and was from the beginning) that when I
> deploy the console(4.1.1), it start a queue (i can configure it in
> WEB-INF/activemq.xml).
>
> Is it possible no to start this queue and to connect to the two queue with
> those params :
> -Dwebconsole.jms.url=failover:(tcp://serverA:61616,tcp://serverB:61616)
> -Dwebconsole.jmx.url=service:jmx:rmi:///jndi/rmi://serverA:1099/jmxrmi,service:jmx:rmi:///jndi/rmi://serverB:1099/jmxrmi
> ?
>
> --
> View this message in context: http://www.nabble.com/two-instances-of-web-amq---one-webconsole-tf4317706s2354.html#a12364752
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
View raw message