activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From W Bainbridge <tysgo...@travelin.com>
Subject JDBC Persistence Problems
Date Mon, 27 Aug 2007 15:15:13 GMT

I'm using ActiveMQ v. 4.1.1 on a Linux machine.  When configured for Oracle
persistence, it runs fine for awhile--a few hours up to a few days--and then
starts getting the checkpoint fails - already started errors (AMQ-1063). 
The relevant configuration is:


    <persistenceAdapter>
        <journaledJDBC journalLogFiles="5"
dataDirectory="${activemq.base}/activemq-data"
               dataSource="#oracle-ds"/>
    </persistenceAdapter>
    
  <bean id="oracle-ds" class="org.apache.commons.dbcp.BasicDataSource"
destroy-method="close">
    <property name="driverClassName"
value="oracle.jdbc.driver.OracleDriver"/>
    <property name="url" value="jdbc:oracle:thin:@[host]:1521:[instance]"/>
    <property name="username" value="activemq"/>
    <property name="password" value="[password]"/>
    <property name="poolPreparedStatements" value="false"/>
  </bean>

Naturally, the stuff in brackets stands for the real values.  I've tried
both true and false for poolPreparedStatements, and neither setting
eliminates the problem.

Since we're not live yet I've just disabled jdbc persistence, but I was
wondering if the problem exists for all DBMSs, or whether there's a solid,
fast DB app I can use for now that will persist OK, until this issue gets
fixed.  DB persistence is one of the things I used to sell management on
ActiveMQ, so it's pretty important for me to get this working as soon as
possible.  Thanks!

W.B.
-- 
View this message in context: http://www.nabble.com/JDBC-Persistence-Problems-tf4336342s2354.html#a12351304
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message