activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Carlson <gshpsr...@charter.net>
Subject Failover error
Date Wed, 22 Aug 2007 19:48:43 GMT

Hi, It appears as thought maxReconnectAttempts is not working in 4.1.1. I
create a ActiveMQConnectionFactory with the url
failover:(tcp://localhost:61616)?initialReconnectDelay=11;maxReconnectDelay=3;maxReconnectAttempts=1
and it never stops trying to reconnect. Here is some of the output from
activeMQ in my logs:
Aug 22,2007 14:42:20,569 DEBUG ActiveMQ Task failover.FailoverTransport -
Attempting connect to: tcp://localhost:61616
Aug 22,2007 14:42:21,757 DEBUG ActiveMQ Task failover.FailoverTransport -
Connect fail to: tcp://localhost:61616, reason: java.net.ConnectException:
Connection refused: connect
Aug 22,2007 14:42:21,757 DEBUG main failover.FailoverTransport - Started.
Aug 22,2007 14:42:21,757 DEBUG ActiveMQ Task failover.FailoverTransport -
Waiting 10 ms before attempting connection. 
Aug 22,2007 14:42:21,772 DEBUG main failover.FailoverTransport - Waiting for
transport to reconnect.
Aug 22,2007 14:42:21,772 DEBUG ActiveMQ Task failover.FailoverTransport -
Attempting connect to: tcp://localhost:61616
Aug 22,2007 14:42:22,788 DEBUG ActiveMQ Task failover.FailoverTransport -
Connect fail to: tcp://localhost:61616, reason: java.net.ConnectException:
Connection refused: connect
Aug 22,2007 14:42:22,788 DEBUG ActiveMQ Task failover.FailoverTransport -
Waiting 20 ms before attempting connection. 
Aug 22,2007 14:42:22,788 DEBUG main failover.FailoverTransport - Waiting for
transport to reconnect.
Aug 22,2007 14:42:22,804 DEBUG ActiveMQ Task failover.FailoverTransport -
Attempting connect to: tcp://localhost:61616
Aug 22,2007 14:42:23,788 DEBUG ActiveMQ Task failover.FailoverTransport -
Connect fail to: tcp://localhost:61616, reason: java.net.ConnectException:
Connection refused: connect
Aug 22,2007 14:42:23,788 DEBUG ActiveMQ Task failover.FailoverTransport -
Waiting 40 ms before attempting connection. 
Aug 22,2007 14:42:23,788 DEBUG main failover.FailoverTransport - Waiting for
transport to reconnect.
Aug 22,2007 14:42:23,835 DEBUG ActiveMQ Task failover.FailoverTransport -
Attempting connect to: tcp://localhost:61616
Aug 22,2007 14:42:24,788 DEBUG ActiveMQ Task failover.FailoverTransport -
Connect fail to: tcp://localhost:61616, reason: java.net.ConnectException:
Connection refused: connect
Aug 22,2007 14:42:24,788 DEBUG ActiveMQ Task failover.FailoverTransport -
Waiting 80 ms before attempting connection. 
Aug 22,2007 14:42:24,788 DEBUG main failover.FailoverTransport - Waiting for
transport to reconnect.
Aug 22,2007 14:42:24,866 DEBUG ActiveMQ Task failover.FailoverTransport -
Attempting connect to: tcp://localhost:61616
Aug 22,2007 14:42:25,804 DEBUG ActiveMQ Task failover.FailoverTransport -
Connect fail to: tcp://localhost:61616, reason: java.net.ConnectException:
Connection refused: connect
Aug 22,2007 14:42:25,804 DEBUG ActiveMQ Task failover.FailoverTransport -
Waiting 160 ms before attempting connection. 
Aug 22,2007 14:42:25,804 DEBUG main failover.FailoverTransport - Waiting for
transport to reconnect.
Aug 22,2007 14:42:25,960 DEBUG ActiveMQ Task failover.FailoverTransport -
Attempting connect to: tcp://localhost:61616
Aug 22,2007 14:42:26,897 DEBUG ActiveMQ Task failover.FailoverTransport -
Connect fail to: tcp://localhost:61616, reason: java.net.ConnectException:
Connection refused: connect

Clearly it is making more than 1 attempt. Is this a known bug? Will it be
fixed.

Thanks 
-- 
View this message in context: http://www.nabble.com/Failover-error-tf4313690s2354.html#a12281668
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message