activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jdemic <john.de...@gmail.com>
Subject Re: Slaving issue on 4.1.1
Date Mon, 13 Aug 2007 18:02:33 GMT

So after some more digging, it appears that the issue is related to this:

2007-08-13 13:55:48,326 [34.79.106:36306] ERROR MasterBroker                  
- Slave Failed
java.lang.AssertionError: Unsupported Method

Which looks like its fixed in the 5.0 release per this incident:
https://issues.apache.org/activemq/browse/AMQ-1257

Does this effectively mean that pure master/slave is broken for 4.1.1?  If
this isn't the case could someone point me to a configuration/workaround
that doesn't involve using a 5.0-SNAPSHOT.

Any help/advice is greatly appreciated...



jdemic wrote:
> 
> Hey All,
> 
> I'm having an issue getting pure master/slave working on activemq 4.1.1. 
> It seems to work fine for a while (maybe an hour) then i see the following
> in the activemq log on my master server:
> 
> 2007-08-11 19:46:39,403 [00.204.13:35485] WARN  AbstractRegion                
> - A duplica
> te subscription was detected. Clients may be misbehaving. Later warnings
> you may see about
>  subscription removal are a consequence of this.
> 
> After this messages are no longer being delivered.
> 
> Any ideas?
> -jd
> 

-- 
View this message in context: http://www.nabble.com/Slaving-issue-on-4.1.1-tf4255212s2354.html#a12131003
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message