activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chahir <chahi...@yahoo.fr>
Subject Problem with performance Test
Date Mon, 13 Aug 2007 12:32:47 GMT

hi,

I've tried to do the performance test with the Maven plugin.
I've built this plugin with mvn install:

[INFO] Scanning for projects...
[INFO]
----------------------------------------------------------------------------
[INFO] Building ActiveMQ :: Performance Test Plugin
[INFO]    task-segment: [install]
[INFO]
----------------------------------------------------------------------------
[INFO] [plugin:descriptor]
[INFO] Using 2 extractors.
[INFO] Applying extractor for language: java
[INFO] Extractor for language: java found 3 mojo descriptors.
[INFO] Applying extractor for language: bsh
[INFO] Extractor for language: bsh found 0 mojo descriptors.
[INFO] [resources:resources]
[INFO] Using default encoding to copy filtered resources.
[INFO] [compiler:compile]
[INFO] Nothing to compile - all classes are up to date
[INFO] [resources:testResources]
[INFO] Using default encoding to copy filtered resources.
[INFO] [compiler:testCompile]
[INFO] Nothing to compile - all classes are up to date
[INFO] [surefire:test]
[INFO] Surefire report directory:
/home/chahir/activemq/activemq-tooling/maven-activemq-perf-plugin/target/surefire-reports

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Running org.apache.activemq.tool.ReflectionUtilTest
Tests run: 5, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.3 sec

Results :
Tests run: 5, Failures: 0, Errors: 0, Skipped: 0

[INFO] [jar:jar]
[INFO] Building jar:
/home/chahir/activemq/activemq-tooling/maven-activemq-perf-plugin/target/maven-activemq-perf-plugin-4.2-SNAPSHOT.jar
[INFO] [plugin:addPluginArtifactMetadata]
[INFO] [install:install]
[INFO] Installing
/home/chahir/activemq/activemq-tooling/maven-activemq-perf-plugin/target/maven-activemq-perf-plugin-4.2-SNAPSHOT.jar
to
/root/.m2/repository/org/apache/activemq/tooling/maven-activemq-perf-plugin/4.2-SNAPSHOT/maven-activemq-perf-plugin-4.2-SNAPSHOT.jar
[INFO] [plugin:updateRegistry]
[INFO] [maven-one-plugin:install-maven-one-repository {execution: default}]
[INFO] Installing
/home/chahir/activemq/activemq-tooling/maven-activemq-perf-plugin/target/maven-activemq-perf-plugin-4.2-SNAPSHOT.jar
to
/root/.maven/repository/org.apache.activemq.tooling/maven-plugins/maven-activemq-perf-plugin-4.2-SNAPSHOT.jar
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 12 seconds
[INFO] Finished at: Sun Aug 12 20:02:57 CEST 2007
[INFO] Final Memory: 10M/19M
[INFO]
------------------------------------------------------------------------

Then, when I've tried to enter maven commands this error appeared:

M1:/home/chahir/activemq/activemq-perftest # mvn activemq-perf:broker
-Durl=broker:tcp://localhost:61616
[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'activemq-perf'.
[INFO] artifact org.apache.activemq:maven-activemq-perf-plugin: checking for
updates from apache.incubating.releases
[INFO] artifact org.apache.activemq:maven-activemq-perf-plugin: checking for
updates from central
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] The plugin 'org.apache.activemq:maven-activemq-perf-plugin' does not
exist or no valid version could be found
[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Sun Aug 12 20:11:47 CEST 2007
[INFO] Final Memory: 3M/6M
[INFO]
------------------------------------------------------------------------


What's the problem?

Thank you.
-- 
View this message in context: http://www.nabble.com/Problem-with-performance-Test-tf4260942s2354.html#a12125374
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message