activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tero <tero_t_vaana...@hotmail.com>
Subject Openwire for .NET has problems with 5.0
Date Tue, 07 Aug 2007 20:48:42 GMT


I using the latest .NET C# client (NMS.ActiveMQ) and I open durable
consumers for a number of topics. I was using AMQ 4.2 server snapshots which
worked fine except for reconnect problems, which was fixed in 4.1.1, and
appears to be fixed in later snapshots of 5.0 trunk. 4.1.1 had out of memory
problems and journal sync issues so I could not use it.

So I tried the latest snapshot for 5.0
(apache-activemq-5.0-20070806.220834-45) to solve the reconnect issues, but
I no longer receive any messages with OpenWire. I tried Stomp, and it works.
I debugged it far enough to see that OpenWire does somekind of hand shake,
but after that the channel goes silent (no disconnect) and there are no more
events received over the TCP connection, though messages are published to
topics.

Any ideas?

-- 
View this message in context: http://www.nabble.com/Openwire-for-.NET-has-problems-with-5.0-tf4232620s2354.html#a12042077
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message