activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Building eclipse project
Date Mon, 30 Jul 2007 16:57:31 GMT
On 7/30/07, Elliotte Harold <erharold@gmail.com> wrote:
> On Windows with Java 5 when I try to run "maven eclipse:eclipse" it dies
> with some XJC schema errors like this:
>
> [INFO] Building ActiveMQ :: XMPP
> [INFO]    task-segment: [eclipse:eclipse]
> [INFO]
> -------------------------------------------------------------------------
> ---
> [INFO] Preparing eclipse:eclipse
> [INFO] [jaxb2:generate {execution: default}]
> [INFO] Removed old generateDirectory 'C:\Documents and
> Settings\eharold\workspac
> e\activemq\activemq-xmpp\target\generated-sources\xjc'.
> [ERROR] XJC while parsing schema(s)
> file:/C:/Documents%20and%20Settings/eharold/
> workspace/activemq/activemq-xmpp/src/main/resources/stanzaerror.xsd[16,48]:
> org.
> xml.sax.SAXParseException: 'bad-request' is already defined
> [ERROR] XJC while parsing schema(s)
> file:/C:/Documents%20and%20Settings/eharold/
> workspace/activemq/activemq-xmpp/src/main/resources/stanzaerror.xsd[16,48]:
> org.
> xml.sax.SAXParseException: (related to above error) the first definition
> appears
>  here
>
>
> Any ideas?

I've not seen that one before. FWIW this part of the build is trying
to use JAXB2 to code generate some POJOs for working with XMPP.

I wonder - could it be to do with being in a directory that has spaces
in it? Does moving the activemq directory to a non-space directory
help?

-- 
James
-------
http://macstrac.blogspot.com/

Mime
View raw message