activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: AltDeploymentRepository Problem...
Date Thu, 12 Jul 2007 14:37:55 GMT
I wonder if you grabbed the source from SVN it'd work?
http://activemq.apache.org/source.html

it could be some maven gremlin thats crept into the generated source tarball?


On 7/11/07, Kit Plummer <christopher_plummer@raytheon.com> wrote:
> I'm trying to build ActiveMQ and deploy it to an "internal" repository.
>   But, it fails:
>
> siryn-apus:~/Desktop/apache-activemq-5.0-SNAPSHOT/src kplummer$ mvn
> deploy:deploy
> -DaltDeploymentRepository="eMAF.repo::default::file:///Users/kplummer/Development/workspace/maven-repository"
> -e
> + Error stacktraces are turned on.
> [INFO] Scanning for projects...
> [INFO] Reactor build order:
> [INFO]   ActiveMQ
> [INFO]   ActiveMQ User Guide
> [INFO]   ActiveMQ :: JAAS
> [INFO]   Openwire Generator
> [INFO]   ActiveMQ :: Core
> [INFO]   ActiveMQ :: Console
> [INFO]   ActiveMQ :: File Server
> [INFO]   ActiveMQ :: JPA Message Store
> [INFO]   ActiveMQ :: Optional
> [INFO]   ActiveMQ :: RA
> [INFO]   ActiveMQ :: RAR
> [INFO]   ActiveMQ :: Atomikos System Test
> [INFO]   ActiveMQ Tooling
> [INFO]   ActiveMQ :: Memory Usage Test Plugin
> [INFO]   ActiveMQ :: Performance Test Plugin
> [INFO]   ActiveMQ :: StartUp Plugin
> [INFO]   ActiveMQ :: Web
> [INFO]   ActiveMQ :: Web Demo
> [INFO]   ActiveMQ :: XMPP
> [INFO]   ActiveMQ :: Web Console
> [INFO]   ActiveMQ :: Assembly
> [INFO] Searching repository for plugin with prefix: 'deploy'.
> [INFO]
> ----------------------------------------------------------------------------
> [INFO] Building ActiveMQ
> [INFO]    task-segment: [deploy:deploy]
> [INFO]
> ----------------------------------------------------------------------------
> [INFO] [deploy:deploy]
> altDeploymentRepository =
> eMAF.repo::default::file:///Users/kplummer/Development/workspace/maven-repository
> [INFO] Using alternate deployment repository
> eMAF.repo::default::file:///Users/kplummer/Development/workspace/maven-repository
> [INFO] Retrieving previous build number from eMAF.repo
> Uploading:
> file:///Users/kplummer/Development/workspace/maven-repository/org/apache/activemq/activemq-parent/5.0-SNAPSHOT/activemq-parent-5.0-SNAPSHOT.pom
> 33K uploaded
> [INFO] Retrieving previous metadata from eMAF.repo
> [INFO] Uploading repository metadata for: 'artifact
> org.apache.activemq:activemq-parent'
> [INFO] Retrieving previous metadata from eMAF.repo
> [INFO] Uploading repository metadata for: 'snapshot
> org.apache.activemq:activemq-parent:5.0-SNAPSHOT'
> [INFO]
> ----------------------------------------------------------------------------
> [INFO] Building ActiveMQ User Guide
> [INFO]    task-segment: [deploy:deploy]
> [INFO]
> ----------------------------------------------------------------------------
> [INFO] [deploy:deploy]
> altDeploymentRepository =
> eMAF.repo::default::file:///Users/kplummer/Development/workspace/maven-repository
> [INFO] Using alternate deployment repository
> eMAF.repo::default::file:///Users/kplummer/Development/workspace/maven-repository
> [INFO] Retrieving previous build number from eMAF.repo
> Uploading:
> file:///Users/kplummer/Development/workspace/maven-repository/org/apache/activemq/activemq-book/5.0-SNAPSHOT/activemq-book-5.0-SNAPSHOT.pom
> 3K uploaded
> [INFO] Retrieving previous metadata from eMAF.repo
> [INFO] Uploading repository metadata for: 'artifact
> org.apache.activemq:activemq-book'
> [INFO] Retrieving previous metadata from eMAF.repo
> [INFO] Uploading repository metadata for: 'snapshot
> org.apache.activemq:activemq-book:5.0-SNAPSHOT'
> [INFO]
> ----------------------------------------------------------------------------
> [INFO] Building ActiveMQ :: JAAS
> [INFO]    task-segment: [deploy:deploy]
> [INFO]
> ----------------------------------------------------------------------------
> [INFO] [deploy:deploy]
> altDeploymentRepository =
> eMAF.repo::default::file:///Users/kplummer/Development/workspace/maven-repository
> [INFO] Using alternate deployment repository
> eMAF.repo::default::file:///Users/kplummer/Development/workspace/maven-repository
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] The packaging for this project did not assign a file to the build
> artifact
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Trace
> org.apache.maven.lifecycle.LifecycleExecutionException: The packaging
> for this project did not assign a file to the build artifact
>          at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:564)
>          at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:493)
>          at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:463)
>          at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)
>          at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:278)
>          at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)
>          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:334)
>          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:125)
>          at org.apache.maven.cli.MavenCli.main(MavenCli.java:280)
>          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>          at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>          at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>          at java.lang.reflect.Method.invoke(Method.java:585)
>          at
> org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>          at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>          at
> org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>          at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.maven.plugin.MojoExecutionException: The packaging
> for this project did not assign a file to the build artifact
>          at
> org.apache.maven.plugin.deploy.DeployMojo.execute(DeployMojo.java:159)
>          at
> org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:443)
>          at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:539)
>          ... 16 more
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 2 seconds
> [INFO] Finished at: Wed Jul 11 13:49:43 MST 2007
> [INFO] Final Memory: 5M/254M
> [INFO]
> ------------------------------------------------------------------------
>
> What am I doing wrong?  This same process worked for ServiceMix...
>


-- 
James
-------
http://macstrac.blogspot.com/

Mime
View raw message