activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From smo <SMOR...@micropole-univers.com>
Subject Re: kaha store corrupted ? 100% CPU on ActiveMQ restart
Date Fri, 20 Jul 2007 13:01:21 GMT

It seems activemq 5.0 clients must use JDK 1.5 (but we are using 1.4), am I
wrong ?



rajdavies wrote:
> 
> you really need to move up to the latest snapshot of 5.0 - or don't  
> use Kaha
> 
> cheers,
> 
> Rob
> 
> On Jul 20, 2007, at 8:57 AM, smo wrote:
> 
>>
>> I don't think there is recovery (I joined the activemq.xml :
>> http://www.nabble.com/file/p11703785/activemq.xml activemq.xml  )
>> The log level is this one : log4j.rootLogger=DEBUG, out, stdout (as
>> recommanded in the log4j.properties for activeMQ team debugging ;) )
>> I'm using ActiveMQ 4.1.0-incubator.
>> Deleting the index-* files ActiveMQ restarts normally but I don't  
>> understand
>> how this files get corrupted. We are using activeMQ on 8 different  
>> servers
>> and they randomly get corrupted whitout any obvious reason that's a  
>> big
>> problem for us.
>>
>>
>> Tom Samplonius-2 wrote:
>>>
>>>
>>> ----- "smo" <SMOREAU@micropole-univers.com> wrote:
>>>> Hi!
>>>> I am facing a problem on restarting ActiveMQ.
>>>> The CPU is at 100% and ActiveMQ is not available. The console  
>>>> hangs on
>>>> this
>>>> line :
>>>> INFO  KahaStore                      - Kaha Store using data
>>>> directory
>>>> c:\ActiveMQ\activemq-data\kaha.db
>>>> Here are the logs :
>>>> http://www.nabble.com/file/p11691575/activeMQlog.txt activeMQlog.txt
>>>>
>>>> Does somebody know what's happening??
>>>
>>>
>>>   Are you sure Kaha is not doing a recovery?  Depending on the  
>>> speed of
>>> your machine, a recovery could take 40 minutes.
>>>
>>>   You log does not indicate a recovery is running, but I don't  
>>> recognize
>>> the log level you are using.
>>>
>>>   You can also try to delete the index files.  They will rebuilt on
>>> startup.  I've never tried this, but was told to try it by one of the
>>> developers because I was hitting the "data--1" bug.
>>>
>>>   Also, what version of ActiveMQ?  Kaha has known bugs in 4.1.1.
>>>
>>>
>>> Tom
>>>
>>>
>>
>> -- 
>> View this message in context: http://www.nabble.com/kaha-store- 
>> corrupted---100--CPU-on-ActiveMQ-restart-tf4111854s2354.html#a11703785
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/kaha-store-corrupted---100--CPU-on-ActiveMQ-restart-tf4111854s2354.html#a11707747
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message