activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wbickford <wixellbickf...@yahoo.com>
Subject Re: Trying to get started: how do I configure Tomcat to run ActiveMQ?
Date Thu, 19 Jul 2007 16:37:11 GMT

I got frustrated with trying to setup jndi configuration when trying to run
as an embedded server.  I'm using Resin (not Tomcat) - I configured directly
from a java startup servlet.  This might help if you just want to get it
running, probably would work with Tomcat.  Here's what I did:
1) Copied all jars from lib directory to my lib.  Did not use the optional
libs.
2) Created a startup servlet with this in the init() method:
        static BrokerService brokerService; ....
        BrokerFactoryBean factoryBean = new BrokerFactoryBean(new
          
FileSystemResource("/opt/resin/webapps/lc/WEB-INF/classes/com/sadromance/mq/activemq.xml"));
        factoryBean.afterPropertiesSet();
        brokerService = factoryBean.getBroker();
3) ** Think this was Resin-specific but had to 3 xalan, xerces libs and
related web.xml entries.
I also had problems using the example programs which had too much bloat in
them to get them running quickly, can provide much simplified versions of
these.

Henk van Voorthuijsen wrote:
> 
> After downloading ActiveMQ 4.1.1, I managed to sucessfully run it as
> stand-alone.
> As a following step, I tried to get Tomcat to start the same process - and
> that's where I get lost!
> 
> I have tried adding a ConnectionFactory and Queue to the
> <GlobalNamingResources> element, and they do show up on the resource page
> of the Tomcat manager, but so far I can see no processes being started.
> 
> A step-by-step description of how to do this would be much appreciated.
> 
> Henk van Voorthuijsen
> 
> PS. My configuration:
> Windows XP
> Tomcat 5.5.17
> ActiveMQ 4.1.1
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Trying-to-get-started%3A-how-do-I-configure-Tomcat-to-run-ActiveMQ--tf4050129s2354.html#a11692805
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message