activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthrope ...@anthrope.com>
Subject Re: ActiveMQ not receiveing msgs over 10KB?
Date Mon, 16 Jul 2007 15:43:35 GMT

In our application, we're sending messages that can be as large as 2MB, and
are able to do so quite alright. We are using queues, and our messages are
always marked with a DELIVERY_MODE of PERSISTENT. It could be possible that
you're using non-persistent messages and have not configured your memory
manager. If that is the case, you can set your memory manager thus:

    <memoryManager>
        <usageManager id="memory-manager" limit="128 MB"/>
    </memoryManager>

The limit is something you set based on the average size of your messages
and how much memory you have available. Apparently, 5.0 supports overflow to
disk for the usageManager, so you're less likely to run into a
hung/deadlocked ActiveMQ instance just because your usageManager hasn't got
enough memory allocated to it.

Prashanth


Eric Lee wrote:
> 
> we get message larger than 20KB!
> 
> 
> ashforduniversity wrote:
>> 
>> Hello,
>> We have ActiveMQ running and we are using Stomp.php to push messages on
>> to it. We have alwways had success until we had the need to send data
>> larger than 10KB which does not get accepted by ActiveMQ at all? We ahve
>> proven that the stomp.php can send any amount of data regardless of size.
>> I have read that ActiveMQ does not have a message size limit and that its
>> bound to the RAM? If so, does anyone know why we dont get messages larger
>> than 10KB?
>> Thanks
>> Wesley
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ-not-receiveing-msgs-over-10KB--tf4013478s2354.html#a11620551
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message