activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hh_meta <helen_...@tvworks.com>
Subject "No subscriptions registered, will not dispatch message at this time." why?
Date Fri, 13 Jul 2007 22:10:32 GMT

I set up a network of brokers: broker A, B and C. and a remote consumer
connects to the broker using multicast URI.

STEP 1: send message from each broker, broker A's message is consumed by
consumer right away. broker B's message is forwarded to broker A, and log
says: "No subscriptions registered, will not dispatch message at this time",
so broker B's message is not consumed. same with broker C.
STEP 2: kill broker A, consumer and 2 remaining brokers have reconnections
happen. now broker B's message is consumed, while broker C's message
forwarded to broker B and still "No subscriptions registered, will not
dispatch message at this time".
STEP 3: kill broker B, after auto-reconection, broker C's message is
consumed finally.

I try to understand why the store-and-forward didn't forward message via
broker to consumer, but stops at some point and complaining about "no
subscription". if broker A knows about a consumer, when message from broker
B forwards to broker A, shouldn't that message got consumed as well? I've
set for each broker: networkTTL=100, dynamicOnly=false,
conduitSubscription=false. Maybe I have a misunderstanding about
store-and-forward concept. 

Thanks for shedding some lights!!
-- 
View this message in context: http://www.nabble.com/%22No-subscriptions-registered%2C-will-not-dispatch-message-at-this-time.%22--why--tf4077174s2354.html#a11588481
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message