activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hh_meta <helen_...@tvworks.com>
Subject Re: network of broker: message does not forward between brokers and to consumer
Date Thu, 12 Jul 2007 16:36:42 GMT

how to ensure NoB links are made? the logs from brokers do have something
about "waking up reconnect task", "adding new broker ...", does that mean
the network has been formed correctly?
Or, do I get an error when the broker is not added to the network?


Kit Plummer wrote:
> 
> I believe this has to do with the timing of the consumer connection and 
> the network creation.  You'll need to ensure that the consumer connects 
> after the NoB links are made.
> 
> hh_meta wrote:
>> broker A, broker B forms a network of brokers. remote consumer connects
>> to
>> the network using multicast discovery, it could connect to any of the
>> brokers in the network, let's say broker B. each broker has a producer.
>> when message sends out via broker B, it sends to consumer right away.
>> when
>> message sends out broker A, it does not forward to broker B as expected,
>> log
>> says "No subscriptions registered, will not dispatch message at this
>> time"
>> 
>> this does not happen alwasys though. broker network TTL set to 100,
>> dynamicOnly is false, conduitSubscription is false.
> 
> 

-- 
View this message in context: http://www.nabble.com/network-of-broker%3A-message-does-not-forward-between-brokers-and-to-consumer-tf4065507s2354.html#a11563845
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message