activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nkiesel <>
Subject Re: Unknown data type: 73 exception in ActiveMQConnection.syncSendPacket
Date Tue, 03 Jul 2007 17:49:19 GMT

James.Strachan wrote:
> Sounds like you are communicating with an old broker; or using the
> incorrect port (e.g. talking to the stomp port or something). Maybe
> turn off the multicast discovery and double check your client jars
> match your broker jars

I switched to the apache-activemq-4.1.1.jar, but that makes no difference. I
also deleted all files from data/journal before starting, but is still dies
in recoverMessage.  Why is it even going there?

What I also noticed was that I did not post the stacktrace of the root cause
of the exception.  The vm.VMTransport.oneway I see in that is also in the
stack trace for my network connector problem, but I think that's just
because both fail while trying to write, no?

The setup I'm using is as follows:
ActiveMQConnectionFactory f = new
Connection aqc = f.createConnection();
session = aqc.createSession(false, Session.AUTO_ACKNOWLEDGE);

and /opt/TBD/sync/aqprimary.xml looks like this (notice I commented out the
network connectors for now):
  <broker brokerName="prim" xmlns=""
      <journaledJDBC journalLogFiles="5" dataDirectory="/opt/TBD/sync/data"
      <networkConnector name="secondary"
uri="static://(tcp://" failover="true">
          <queue physicalName="compile.>"/>
          <queue physicalName="seccompile.>"/>
  <bean id="oracle-ds" class="oracle.jdbc.pool.OracleDataSource">
    <property name="URL" value="jdbc:oracle:thin:@aaa:1521:tbddb"/>
    <property name="user" value="xxx"/>
    <property name="password" value="yyy"/>

(Just posting all of this here because I still think I'm doing something
stupidly wrong)


View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message