activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Basic Spring+AMQ+XBean+embededbroker problem
Date Thu, 21 Jun 2007 07:55:00 GMT
This line was the giveaway...


On 6/21/07, Paul Smith <psmith@aconex.com> wrote:
[snip]

> Caused by: java.lang.ClassNotFoundException:
> org.apache.xbean.spring.context.v2c.XBeanNamespaceHandler
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
>         at java.security.AccessController.doPrivileged(Native Method)


Try adding this dependency...

    <dependency>
      <groupId>org.apache.xbean</groupId>
      <artifactId>xbean-spring</artifactId>
      <version>2.8</version>
    </dependency>


As xbean-spring was built to support both spring 1.x and 2.x so its in
2 modules, the core and the spring 2 specific stuff.

>From 3.x onwards, xbean-spring just depends on spring 2 so AFAIK its one module

-- 
James
-------
http://macstrac.blogspot.com/

Mime
View raw message