activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: concurrent.util backport
Date Wed, 13 Jun 2007 14:28:05 GMT
On 6/13/07, Elliotte Harold <erharold@gmail.com> wrote:
> Why does ActiveMQ require the backport of java.concurrent.util? I'm working
> in Java 5 and would be happy to use the regular, bundled version of
> java.util.concurrent,  which I suspect works better anyway. Is there any
> chance to get a version of ActiveMQ that removes this external dependency?

Version 5.0 or later uses Java 5 and java.util.concurrent. Its not yet
released (though hopefully fairly soon now).

There's a snapshot distro here if you want to tinker...
http://people.apache.org/repo/m2-snapshot-repository/org/apache/activemq/apache-activemq/

The 5.0-SNAPSHOT should be up shortly; we had an issue with
permissions in the repo (again!) stopping the nightly CI build from
working.

For now the 4.2-SNAPSHOT should be a good substitute though in an hour
or so the 5.0-SNAPSHOT should be there.


-- 
James
-------
http://macstrac.blogspot.com/

Mime
View raw message