activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mario Siegenthaler" <msiegentha...@inventsoft.ch>
Subject Re: network of brokers: transports disposed every second
Date Sat, 30 Jun 2007 16:27:17 GMT
I think you need to name the two brokers differently. It seems like
you named both of them "localhost".

Mario

On 6/30/07, nkiesel <nkiesel@tbdnetworks.com> wrote:
>
> Hi,
>
> I'm using 4.1.1 and try to set up a network of 2 brokers:
> aqprimary.xml has
>    <networkConnectors>
>       <networkConnector name="sec" uri="static//:(tcp://192.168.4.45:61618)"
> networkTTL="2"/>
>    </networkConnectors>
>
> and aqsecondary.xml has
>    <transportConnectors>
>       <transportConnector uri="tcp://localhost:61618"/>
>     </transportConnectors>
>
> When starting the primary with the secondary already running, I see lots of
> the following with ever increasing vm://localhost#:
>
> 19:33:07,153 INFO  [NetworkConnector] Establishing network connection
> between from vm://localhost?network=true to tcp://192.168.4.45:61618
> 19:33:07,173 INFO  [DemandForwardingBridge] Network connection between
> vm://localhost#4 and tcp:///192.168.4.45:61618(localhost) has been
> established.
> 19:33:07,554 ERROR [DurableConduitBridge] Failed to add static destination
> queue://secondary.top
> org.apache.activemq.transport.TransportDisposedIOException: Peer
> (vm://localhost#5) disposed.
>         at
> org.apache.activemq.transport.vm.VMTransport.oneway(VMTransport.java:86)
>         at
> org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:47)
>         at
> org.apache.activemq.transport.ResponseCorrelator.oneway(ResponseCorrelator.java:60)
>         at
> rg.apache.activemq.network.DemandForwardingBridgeSupport.addSubscription(DemandForwardingBridgeSupport.java:451)
>         at
> org.apache.activemq.network.DurableConduitBridge.setupStaticDestinations(DurableConduitBridge.java:64)
>         at
> org.apache.activemq.network.DemandForwardingBridgeSupport.startLocalBridge(DemandForwardingBridgeSupport.java:241)
>         at
> org.apache.activemq.network.DemandForwardingBridgeSupport$3.run(DemandForwardingBridgeSupport.java:198)
> 19:33:07,555 INFO  [DemandForwardingBridge] Network connection between
> vm://localhost#4 and tcp:///192.168.4.45:61618 shutdown due to a remote
> error: org.apache.activemq.transport.TransportDisposedIOException: Peer
> (vm://localhost#5) disposed.
>
>
> Any idea what I'm doing wrong?  I use Oracle in a persistenceAdapter on both
> sides.
>
> Best,
>   Norbert
>
> --
> View this message in context: http://www.nabble.com/network-of-brokers%3A-transports-disposed-every-second-tf4003251s2354.html#a11370037
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
View raw message