activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Samplonius <...@samplonius.org>
Subject Re: Recommended version of ActiveMQ?
Date Thu, 07 Jun 2007 21:12:21 GMT

----- "James Strachan" <james.strachan@gmail.com> wrote:
> On 5/30/07, Tom Samplonius <tom@samplonius.org> wrote:
> >
> >   Ok, but Stomp is buggy in 4.1.1.  ActiveMQ 4.1.1 loses
> un-acknowledged messages if your consumer crashes without sending a
> DISCONNECT message.
> >
> >   So, I guess I need to use a 4.2-SNAPSHOT, but which vintage is not
> going to burn me (too bad)?
> 
> As soon as the 4.2 is released I"d recommend moving to that.

  I was looking for specific advice on _which_ 4.2-SNAPSHOT to use.  Some are probably better
than others.


> >   Right out of the gate, 4.2 is unable to count how many messages
> are in persistent storage on startup.  But that bug is just annoying.
> 
> As was said in a different thread; you can disable the AMQStore and
> use the stable JDBC/Journal persistence.

  Ok, but it doesn't matter whether Derby+Joural or Kaha are used.  It is pretty easy to switch
back and forth, and I've tried both.  Message count is "0" at startup, no matter how many
messages are in the persistent storage.



> -- 
> James
> -------
> http://macstrac.blogspot.com/


Mime
View raw message