activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nkiesel <nkie...@tbdnetworks.com>
Subject Re: network of brokers: transports disposed every second
Date Sun, 01 Jul 2007 01:17:47 GMT


Mario Siegenthaler-2 wrote:
> 
> I think you need to name the two brokers differently. It seems like
> you named both of them "localhost".
> 
> Mario
> 

Thanks. I fixed that (by adding brokerName="primary" to aqprimary.xml and
brokerName="secondary" to aqsecondary.com), but the problem is still there
(though it now shows the name "secondary").  This is after some minutes, so
the number behind vm://primary# have increased to 1336 at this point:

18:06:03,963 INFO  [TransportConnector] Connector vm://primary Started
18:06:03,975 INFO  [DemandForwardingBridge] Network connection between
vm://primary#1336 and tcp:///192.168.4.45:61618(secondary) has been
established.
18:06:04,589 ERROR [DurableConduitBridge] Failed to add static destination
queue://secondary.top
org.apache.activemq.transport.TransportDisposedIOException: Peer
(vm://primary#1337) disposed.
        at
org.apache.activemq.transport.vm.VMTransport.oneway(VMTransport.java:86)
        at
org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:47)
        at
org.apache.activemq.transport.ResponseCorrelator.oneway(ResponseCorrelator.java:60)
        at
org.apache.activemq.network.DemandForwardingBridgeSupport.addSubscription(DemandForwardingBridgeSupport.java:451)
        at
org.apache.activemq.network.DurableConduitBridge.setupStaticDestinations(DurableConduitBridge.java:64)
        at
org.apache.activemq.network.DemandForwardingBridgeSupport.startLocalBridge(DemandForwardingBridgeSupport.java:241)
        at
org.apache.activemq.network.DemandForwardingBridgeSupport$3.run(DemandForwardingBridgeSupport.java:198)
18:06:04,590 INFO  [DemandForwardingBridge] Network connection between
vm://primary#1336 and tcp:///192.168.4.45:61618 shutdown due to a remote
error: org.apache.activemq.transport.TransportDisposedIOException: Peer
(vm://primary#1337) disposed.
18:06:04,590 ERROR [DurableConduitBridge] Failed to add static destination
queue://secondary.manual
org.apache.activemq.transport.TransportDisposedIOException: Peer
(vm://primary#1337) disposed.
        at
org.apache.activemq.transport.vm.VMTransport.oneway(VMTransport.java:86)
        at
org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:47)
        at
org.apache.activemq.transport.ResponseCorrelator.oneway(ResponseCorrelator.java:60)
        at
org.apache.activemq.network.DemandForwardingBridgeSupport.addSubscription(DemandForwardingBridgeSupport.java:451)
        at
org.apache.activemq.network.DurableConduitBridge.setupStaticDestinations(DurableConduitBridge.java:64)
        at
org.apache.activemq.network.DemandForwardingBridgeSupport.startLocalBridge(DemandForwardingBridgeSupport.java:241)
        at
org.apache.activemq.network.DemandForwardingBridgeSupport$3.run(DemandForwardingBridgeSupport.java:198)
18:06:04,591 INFO  [TransportConnector] Connector vm://primary Stopped
18:06:04,593 INFO  [NetworkConnector] Establishing network connection
between from vm://primary?network=true to tcp://192.168.4.45:61618
18:06:04,595 INFO  [TransportConnector] Connector vm://primary Started


What I see from above is that it first says: "Network connection between
vm://primary#1336 and tcp:///192.168.4.45:61618(secondary) has been
established" and then says: "Failed to add static destination
queue://secondary.top
org.apache.activemq.transport.TransportDisposedIOException: Peer
(vm://primary#1337) disposed.". So it seems there are 2 vm://primary
instances and the 2nd one makes the first 1 fail.

I still think I'm doing something stupid, because my setup seems very
simple.

Best,
  Norbert

-- 
View this message in context: http://www.nabble.com/network-of-brokers%3A-transports-disposed-every-second-tf4003251s2354.html#a11378441
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message