activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dooart <thiagocdua...@yahoo.com.br>
Subject Re: ActiveMQ, Clustered JBoss and JDBC Master/Slave
Date Fri, 29 Jun 2007 17:55:25 GMT

Sambit, we gave up doing it this way. We have tried JBossMQ too, but we faced
very similar persistence issues, so we arrived at the conclusion that JMS
itself was not a very good choice to manage the nodes of a cluster. We've
ended up using JGroups to implement an IP-multicast based cluster manager
and it worked fine.

Sorry for not being able to help. I hope you can find a solution.

Regards,

Thiago



sambit wrote:
> 
> Hi Thiago,
>   We were also trying to use a similar set up with Jboss and ActiveMQ
> Embedded broker. We are facing same issues as you have mentioned. I'm
> wondering could you finally able to resolve this and can you suggest what
> is the best practice to use ActiveMQ broker, Jboss, MDB for a highly
> scalable and performant requirement. 
> 
> Regards
> -Sambit 
> 
> dooart wrote:
>> 
>> The other one is identical, except for the brokerName, that is
>> brokderDELL07VM1.
>> 
>> Thanks,
>> 
>> Thiago
>> 
>> 
>> rajdavies wrote:
>>> 
>>> Hi Thiago,
>>> 
>>> there only seems to be one broker config file - for broker  -  
>>> brokerDELL07.
>>> Could you send the other one too please ?
>>> 
>>> cheers,
>>> 
>>> Rob
>>> 
>>> On 2 Sep 2006, at 00:29, dooart wrote:
>>> 
>>>>
>>>> Oops... I forgot to attach the configuration files:
>>>> http://www.nabble.com/user-files/235843/configuration_files.zip
>>>> configuration_files.zip
>>>>
>>>> Thiago Duarte
>>>>
>>>>
>>>> dooart wrote:
>>>>>
>>>>> I am trying to setup an environment with a clustered JBoss and  
>>>>> ActiveMQ in
>>>>> JDBC Master/Slave mode. I'm going to use JMS in our application to  
>>>>> help in
>>>>> some issues with clustering, like indexing and local files
>>>>> synchronization.
>>>>>
>>>>> I have only two machines to run the entire environment and I want  
>>>>> to run
>>>>> an embedded ActiveMQ broker per application server to help in  
>>>>> application
>>>>> maintenance, so the final environment will be something like this:
>>>>>
>>>>> At first it seemed to be working fine, but when I started to test the
>>>>> behaviour of the environment shutting down the nodes and  
>>>>> restarting them,
>>>>> I started to have some problems with message duplication and lost
>>>>> messages. Here are the results of some tests I made (errors are  
>>>>> marked
>>>>> with red color):
>>>>>
>>>>> ...
>>>>>
>>>>> I've run the first test with MySQL 5.0 and the second test with MSSQL
>>>>> Server 2000 as datasources for JDBC Master/Slave, but both  
>>>>> configurations
>>>>> failed as you can see at the two tables above. I'm almost sure  
>>>>> that the
>>>>> steps 4 and 5 from the second test failed not because of MSSQL, but
>>>>> because the instability of the entire environment.
>>>>>
>>>>> Does anyone have a clue of what can be wrong? I don't know if this  
>>>>> helps,
>>>>> but I've attached my configuration files here.
>>>>>
>>>>> I'm using JBoss 4.0.4 GA and ActiveMQ 4.1 (I was using 4.0.1  
>>>>> before, but
>>>>> it didn't work too).
>>>>>
>>>>>
>>>>> Thanks,
>>>>>
>>>>> Thiago Duarte
>>>>>
>>>>
>>>> -- 
>>>> View this message in context: http://www.nabble.com/ActiveMQ%2C- 
>>>> Clustered-JBoss-and-JDBC-Master-Slave-tf2204736.html#a6107815
>>>> Sent from the ActiveMQ - User forum at Nabble.com.
>>>>
>>> 
>>> 
>>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ%2C-Clustered-JBoss-and-JDBC-Master-Slave-tf2204736s2354.html#a11364429
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message