activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lawrence Giam <>
Subject Setting up JMX
Date Thu, 28 Jun 2007 06:51:26 GMT


I have installed the followings on my test server which is running Debian
Etch R0:
1. Tomcat 6.0.13
2. JDK 1.6u1
3. ActiveMQ 4.1.1

I was trying to set up the JMX to monitor ActiveMQ but I can't seem to get
it working. I have followed the instructions given on ActiveMQ site. Below
are the configuration of ActiveMQ.

    <!-- Use the following to configure how ActiveMQ is exposed in JMX -->
              <managementContext createConnector="false"/>


I have taken out the SSL so the ActiveMQ startup without SSL options but
when I do a "netstat -ln", the jmxremote.port 4001 is not there.

Next I tried the followings:
    <!-- Use the following to configure how ActiveMQ is exposed in JMX -->
       <managementContext connectorPort="1080" jmxDomainName=""/>

When I tried to start ActiveMQ, I got this error message
"WARN  ManagementContext - Failed to start jmx connector:

Next I tried the method that was mentioned in, I am able to use
jConsole to connect to my test server but I cannot see the ActiveMQ queue in

Can someone tell me how to configure the JMX in ActiveMQ?

View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message