activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jiang <zju_...@163.com>
Subject Re: UDP buffer problem
Date Thu, 21 Jun 2007 01:59:40 GMT

I still not find the correct way to resolve this problem. I have changed the
replayBufferCommandCount to 1000 and compiled the source code . Then I
replaced the ReliableTransport.class in the lib. But when I run the client,
it was the same.  "Request for buffer xx is no longer present" in eclipse
console and in windows cmd console it throw "duplicate message be
discarded". 
Why ? Any one can give some help? Thanks

Jiang wrote:
> 
> I config UDP in activemq.xml to use udp transport. But When I register 20
> consumer and 1 producer in one destination, I find if I send several
> messages , broker will throw: "Request for buffer xx is no longer present"
> in console . After I view the udp code , I think maybe it is caused by the
> udp buffer size( default 50 ) , what I think is correct ? How can I use
> code to change the default size or maybe it can changed through
> activemq.xml ? (When connection is created by connectionfactory I don't
> find how to change the udp transport buffer size )
> 

-- 
View this message in context: http://www.nabble.com/UDP-buffer-problem-tf3899903s2354.html#a11225458
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message