activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: ActiveMQ 4.1.1 MS SQL Server 2005 ACTIVEMQ_MSGS not found
Date Wed, 09 May 2007 17:50:17 GMT
The important line of the log is....

On 5/4/07, kbd <KDuffy@escholar.com> wrote:
>
> Hello:
>
> I am attempting to use MS SQL Server 2005 for persistence storage.
> My ACTIVEMQ.XML is below.  Please note I added the useDatabaseLock="false"
> to   <persistenceAdapter>
> as per a posting on this site.  Made a prior issue go away.
>
> Now when I boot ActiveMQ 4.1.1 I get the following:
>
>
> C:\ProgFiles\apache-activemq-4.1.1>bin\activemq
> ACTIVEMQ_HOME: C:\ProgFiles\apache-activemq-4.1.1\bin\..
> ACTIVEMQ_BASE: C:\ProgFiles\apache-activemq-4.1.1\bin\..
> Loading message broker from: xbean:activemq.xml
> INFO  BrokerService                  - ActiveMQ 4.1.1 JMS Message Broker
> (eDM) is starting
> INFO  BrokerService                  - For help or more information please
> see: http://incubator.apache.org/activemq/
> WARN  JDBCPersistenceAdapter         - Database driver NOT recognized:
> [microsoft_sql_server_2005_jdbc_driver].  Will use def
> ault JDBC implementation.

The above indicates you're using a JDBC driver we don't yet support -
which is why the SQL fails to create the ACTIVEMQ_MSGS table. So you
could try switch to using the jtds JDBC driver. Failing that I've just
added support for this driver to 4.2-SNAPSHOT so you could try
tomorrows nightly build (or build the latest code from svn) and see if
it fixes your issue

-- 
James
-------
http://macstrac.blogspot.com/

Mime
View raw message