activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Snyder" <bruce.sny...@gmail.com>
Subject Re: Creating Network of Brokers
Date Wed, 23 May 2007 15:37:57 GMT
On 5/23/07, Vinod_mit <vinu.mm@gmail.com> wrote:
>
>
> I tried the above iam getting some errors, because my network of brokers not
> working .
>
> i created one first system like this inthe first comuter
>
>                 <transportConnectors>
>                         <transportConnector name="openwire" uri="tcp://localhost:61616"/>
>                 </transportConnectors>
>
>                 <networkConnectors>
>
>                         <networkConnector name="host1 and host2"
> uri="static:/(tcp://localhostsecondsys:61616,tcp://localhostsecondsys:61616)"/>
>
>                 </networkConnectors>
>
> and second like this in the second computer
>
>                 <transportConnectors>
>                         <transportConnector name="openwire" uri="tcp://localhost:61616"/>
>                 </transportConnectors>
>
>                 <networkConnectors>
>
>                         <networkConnector name="host1 and host2"
> uri="static:/(tcp://localhostfirstsys:61616,tcp://localhostfirstsys:61616)"/>
>
>                 </networkConnectors>
>
> when i test this appication from first computer i cannot see the message
> info in the second computer. can any one help me
> how to do it with an example.

If these computers are on the same subnet, the easiest way to get a
network of brokers operational within minutes is to simply use the
default configuration which uses multicast. Below are the
instructions:

1) From host one, cd into the examples directory and run 'ant
producer'. This will send 10 messages to a queue named TEST.FOO.

2) From host two, cd into the examples directory and run 'ant
consumer' This will receive the 10 messages from the queue named
TEST.FOO.

Only once this works properly would I suggest changing the
configuration to something more custom. This ensures that the network
of brokers is, in fact, working correctly before any customizations
take place.

I always use this method when setting up a new network of brokers just
to ensure that everything is OK. Two days ago I set up a new network
of brokers using the default settings and discovered a networking
issue that had to be fixed before the network of brokers would operate
correctly.

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

Apache Geronimo - http://geronimo.apache.org/
Apache ActiveMQ - http://activemq.org/
Apache ServiceMix - http://servicemix.org/
Castor - http://castor.org/

Mime
View raw message