activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From felipera <folive...@livedatagroup.com>
Subject Shared File System Master Slave with OCFS
Date Thu, 17 May 2007 19:25:30 GMT

Hi everyone,

I am trying to setup two MQ Servers (4.1.1), sharing the same data directory
(I tried Derby and Kaha), on top of OCFS, but the locking doesn't seem to be
working. It works fine when both MQs are running on the same server (still
using OCFS). I see the second MQ waiting for the lock to be released
("Journal is locked... waiting 10 seconds for the journal to be unlocked.").
That's why I am not sure if it's a OCFS issue. But when I run each MQ in
separate boxes (still sharing the same data directory using OCFS) it doesn't
work, they both start successfully.

I tried using jdbc:
<journaledJDBC journalLogFiles="5" useDatabaseLock="true"
dataDirectory="${activemq.base}/activemq-data"/>

And Kaha:
<kahaPersistenceAdapter dir="${activemq.base}/activemq-data"
maxDataFileLength="33554432"/>

I am thinking about using a network of brokers, since I don't know what else
to try. I tried with ActiveMQ 4.2 without luck either.

Could you someone help me please?

Thank you in advance,
Felipe
-- 
View this message in context: http://www.nabble.com/Shared-File-System-Master-Slave-with-OCFS-tf3773841s2354.html#a10670741
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message