activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From didyeah971 <didyeah...@yahoo.fr>
Subject Re: Problem for installin ActiveMQ CPP on MAC OS X Tiger
Date Mon, 14 May 2007 13:00:56 GMT

As I said this my config too, and mac ports, and cppunits are installed in
opt/local/lib. I am really lost now...
Did

didyeah971 wrote:
> 
> Yes this my configuration too...
> 
> nmittler wrote:
>> 
>> I've just upgraded my darwinports to the latest macports (renamed)
>> v1.440and also upgraded cppunit and the automake tools and everything
>> works for
>> me.  My guess is that there must be a problem with your installation of
>> macports.  For some reason, the build isn't finding your cppunit
>> libraries
>> ... assuming the error you're getting is still:  macro `AM_PATH_CPPUNIT'
>> not
>> found in library
>> 
>> On my system, the mac ports (including cppunit) are installed in
>> /opt/local/lib.  Is that your configuration?  and if so, is cppunit in
>> there?
>> 
>> 
>> On 5/10/07, didyeah971 <didyeah971@yahoo.fr> wrote:
>>>
>>>
>>> there's no './configure' yet because the error occurs when i launch
>>> ./autogen.sh ...
>>> There's just 'configure.ac' ...
>>> Did
>>>
>>> tabish121 wrote:
>>> >
>>> > Have you tried using the options for the configure script?
>>> >
>>> >   --with-cppunit-prefix=PFX   Prefix where CppUnit is installed
>>> > (optional)
>>> >   --with-cppunit-exec-prefix=PFX  Exec prefix where CppUnit is
>>> installed
>>> > (optional)
>>> >
>>> >
>>> > ./configure --help will show you all the options
>>> >
>>> > On Wed, 2007-05-09 at 07:17 -0700, didyeah971 wrote:
>>> >> I tried a new cpp-unit install (v1.12.0) thanks to macports and the
>>> >> cppunit
>>> >> libs seems to be installed in '/opt/local/lib'.
>>> >>
>>> >> A binary (cppunit-config) is installed in opt/local/bin
>>> >> Actually, i cannot launch ./configure (if you're speaking about the
>>> >> amqcpp
>>> >> one) because the error occurs when i launch ./autogen.sh
>>> >>
>>> >>
>>> >> tabish121 wrote:
>>> >> >
>>> >> > Where does the cppunit stuff get installed?  By default on Linux
if
>>> you
>>> >> > use the src distribution to install cppunit it puts itself in
>>> >> /usr/local
>>> >> > and can't be found by the autoconf scripts, so you have to manually
>>> set
>>> >> > the prefix to /usr i.e ./configure --prefix=/usr I don't know if
>>> >> > something similar is happening on your Mac.
>>> >> >
>>> >> > On Wed, 2007-05-09 at 02:21 -0700, didyeah971 wrote:
>>> >> >> I followed the specific install for mac os x ( ./configure
, make
>>> and
>>> >> >> make
>>> >> >> install,  with flags) on this
>>> >> >>
>>> >>
>>> http://cppunit.sourceforge.net/cppunit-wiki/BuildingCppUnit1#head-67706fd38aa0040e96664d7bc40157f1b9df5650
>>> >> >> site
>>> >> >> I updated autoconf thanks to MacPort, and i still have the
same
>>> error.
>>> >> >> it's the first time i use these tools so i am kind of lost...
>>> >> >>
>>> >> >> Mittler, Nathan wrote:
>>> >> >> >
>>> >> >> > I have autoconf v2.60 on OS X 10.4.9 and it works fine
for me.
>>> >> >> >
>>> >> >> > How did u install cppunit?
>>> >> >> >
>>> >> >> >> -----Original Message-----
>>> >> >> >> From: didyeah971 [mailto:didyeah971@yahoo.fr]
>>> >> >> >> Sent: Friday, May 04, 2007 12:34 PM
>>> >> >> >> To: users@activemq.apache.org
>>> >> >> >> Subject: Problem for installin ActiveMQ CPP on MAC
OS X Tiger
>>> >> >> >>
>>> >> >> >>
>>> >> >> >> Hi,
>>> >> >> >> I am trying install  activemq cpp 2.0 on mac os x
10.4.9.As
>>> >> >> >> the automake supplied is obsolete, i am using the
latest
>>> >> >> >> release, (1.9.6) and cppunit
>>> >> >> >> 1.11.6
>>> >> >> >> Once i launch autogen.sh, i have this message:
>>> >> >> >>
>>> >> >> >> aclocal: configure.ac: 86: macro `AM_PATH_CPPUNIT'
not found
>>> >> >> >> in library
>>> >> >> >> autoreconf: aclocal failed with exit status: 1
>>> >> >> >>
>>> >> >> >> What could be the issue, bad cppunit install (i did
it and
>>> >> >> >> redid it many
>>> >> >> >> times) or bad version or autoconf (the one used is
2.59)
>>> >> >> >>
>>> >> >> >> Thx for help
>>> >> >> >> Did
>>> >> >> >> --
>>> >> >> >> View this message in context:
>>> >> >> >> http://www.nabble.com/Problem-for-installin-ActiveMQ-CPP-on-MA
>>> >> >> >> C-OS-X-Tiger-tf3692575s2354.html#a10324437
>>> >> >> >> Sent from the ActiveMQ - User mailing list archive
at
>>> Nabble.com.
>>> >> >> >>
>>> >> >> >>
>>> >> >> >
>>> >> >> >
>>> >> >>
>>> >> >
>>> >> >
>>> >>
>>> >
>>> >
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/Problem-for-installing-ActiveMQ-CPP-on-MAC-OS-X-Tiger-tf3692575s2354.html#a10408796
>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>>
>>>
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Problem-for-installing-ActiveMQ-CPP-on-MAC-OS-X-Tiger-tf3692575s2354.html#a10602870
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message