activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Garner, Shawn" <shawn.gar...@vangent.com>
Subject RE: question on BrokerFactoryBean
Date Tue, 17 Apr 2007 16:42:17 GMT
<bean id="broker" class="org.apache.activemq.xbean.BrokerFactoryBean">
		<property name="config" value="classpath:activemq.xml"
/>
		<property name="start" value="true" />
	</bean>

	<bean id="jmsResourceAdapter"
class="org.apache.activemq.ra.ActiveMQResourceAdapter"
depends-on="broker">
		<property name="serverUrl" value="vm://localhost"/>
	</bean>

...

<!-- Connection Manager -->
	<bean id="connectionManager"
class="org.jencks.factory.ConnectionManagerFactoryBean">
	  <property name="transactionManager"
ref="jencksTransactionManager"/>
	  <property name="poolMaxSize" value="10"/>
    	<property name="poolMinSize" value="1"/>
    	<property name="pooling" value="true"/>
    	<property name="connectionMaxIdleMinutes" value="1"/>
    	<property name="connectionMaxWaitMilliseconds" value="10000"/>
	</bean>

	<!--  JMS Managed Connection Factory  -->
	<bean id="jmsManagedConnectionFactory"
class="org.apache.activemq.ra.ActiveMQManagedConnectionFactory">
		<property name="resourceAdapter"
ref="jmsResourceAdapter"/>
		<property name="maximumRedeliveries" value="5"/>
		<property name="initialRedeliveryDelay" value="1000"/>
		<property name="redeliveryBackOffMultiplier" value="5"/>
		<property name="redeliveryUseExponentialBackOff"
value="true"/>
	</bean>

Shawn
 
(o) 319-665-7796
(c) 319-480-4409
(f) 319-665-7979
 
Updated email address: shawn.garner@vangent.com
Visit our new web site: www.vangent.com 

-----Original Message-----
From: James Strachan [mailto:james.strachan@gmail.com] 
Sent: Tuesday, April 17, 2007 10:55 AM
To: users@activemq.apache.org
Subject: Re: question on BrokerFactoryBean

On 4/17/07, Garner, Shawn <shawn.garner@vangent.com> wrote:
> Actually now it appears my messages are not being redelivered at all.
> I have it configured for number of redeliveries etc on the
> org.apache.activemq.ra.ActiveMQManagedConnectionFactory.
>
> What should I check to get it working?

What exactly are you doing? You using Jencks I presume? I take it your
configuring the Resource Adapter with the redelivery policy?
-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message