activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jianxiac <jianx...@gmail.com>
Subject AMQ 4.1 loses every other message?
Date Thu, 05 Apr 2007 21:16:48 GMT


I am running the web-demo example with the REST interface, 
and it seems I can only receive every other posted messages. Here are
the simple scripts I used to do the test: 

First, I posted 10 messages with this script: 

[me@a ~]$ cat run-post.sh
#! /bin/sh

ip=10.0.0.3

for i in `seq -w 1 10`; do

echo Posting msg $i:
cat > post-data.txt <<EOF
destination=FOO.BAR&type=topic&body=%3C%3Fxml+version%3D%221.0%22+encoding%3D%22UTF-8%22%3F%3E%0D%0A++%3Ctitle%3EMsg+no.+$i%3C%2Ftitle%3E%0D%0A+
EOF

wget -O tmp.out -o /dev/null --post-file post-data.txt
http://$ip:8080/activemq-web-demo/message/FOO/BAR

done

And it ran fine, 

[me@a ~]$ ./run-post.sh
Posting msg 01:
Posting msg 02:
Posting msg 03:
Posting msg 04:
Posting msg 05:
Posting msg 06:
Posting msg 07:
Posting msg 08:
Posting msg 09:
Posting msg 10:

The I fired up a message read script, shown here:

[me@a ~]$ cat run-read.sh
#! /bin/sh
ip=10.0.0.3

# wget -O - --save-cookies cookies --keep-session-cookies
http://$ip:8080/activemq-web-demo/message/FOO/BAR?timeout=10000\&type=topic

for i in `seq -w 1 10`; do

echo Getting msg $i:
wget -O - -o /dev/null --load-cookies cookies
http://$ip:8080/activemq-web-demo/message/FOO/BAR?timeout=10000\&type=topic

done

But when it ran, it had: 

[me@a ~]$ ./run-read.sh
Getting msg 01:

  <title>Msg no. 01</title>

Getting msg 02:

  <title>Msg no. 03</title>

Getting msg 03:

  <title>Msg no. 05</title>

Getting msg 04:

  <title>Msg no. 07</title>

Getting msg 05:

  <title>Msg no. 09</title>

Getting msg 06:

Then it stuck there until timeout. So apparently it only got the
odd-numbered message in 
the topic. Sometimes it got all the even-numbered ones. But it never got 'em
all. 

Jconsole showed there is only one consumer. 

I am wondering if others have similar issue. 

Thanks.





-- 
View this message in context: http://www.nabble.com/AMQ-4.1-loses-every-other-message--tf3533954s2354.html#a9864016
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message