activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nbreau <nbr...@rogers.com>
Subject ActiveMQ 4.1.1 Producer Blocks, but gives error in 4.2
Date Wed, 25 Apr 2007 15:24:03 GMT


Hi Everyone,

We're using activemq publishing about one ObjectMessage every 2-3 seconds.
No problems with the consumers (messages consumed right away), however the
producers seem to block after about 2000-3000 messages) in 4.1.1

I tried out 4.2 and the blocking no longer occurs, however once i reach the
2000-3000 threshold one of about every 8-10 messages generates the following
stack trace.  Any help in terms of what the issue could be would be greatly
appreciated.

Running on a 64bit ubuntu box, java 1.5

javax.jms.JMSException: The transport is not running.
        at
org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:58)
        at
org.apache.activemq.ActiveMQConnection.asyncSendPacket(ActiveMQConnection.java:1157)
        at
org.apache.activemq.ActiveMQConnection.close(ActiveMQConnection.java:580)
        at
services.mq.WidgetManagementMQProducer.publishBlogPostToWidgetManagement(WidgetManagementMQProducer.java:76)
 
Caused by: java.io.IOException: The transport is not running.
        at
org.apache.activemq.transport.TransportSupport.checkStarted(TransportSupport.java:103)
        at
org.apache.activemq.transport.tcp.TcpTransport.oneway(TcpTransport.java:117)
        at
org.apache.activemq.transport.InactivityMonitor.oneway(InactivityMonitor.java:141)
        at
org.apache.activemq.transport.TransportFilter.oneway(TransportFilter.java:80)
        at
org.apache.activemq.transport.WireFormatNegotiator.oneway(WireFormatNegotiator.java:93)
        at
org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:44)
        at
org.apache.activemq.transport.ResponseCorrelator.oneway(ResponseCorrelator.java:60)
        at
org.apache.activemq.ActiveMQConnection.asyncSendPacket(ActiveMQConnection.java:1155)
        ... 15 more



thanks,
Nick.


-- 
View this message in context: http://www.nabble.com/ActiveMQ-4.1.1-Producer-Blocks%2C-but-gives-error-in-4.2-tf3646005s2354.html#a10182916
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message