activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Durable Subscription and Message Expiration
Date Thu, 08 Mar 2007 09:06:41 GMT
Hmm. Are you using a queue rather than a topic? As you can't browse
the contents of topics via JMX.
http://activemq.apache.org/how-does-a-queue-compare-to-a-topic.html

On 3/8/07, teryz <teryzplace@gmail.com> wrote:
>
> Indeed, it is NON_PERSISTENT.
> is this the source of the problem?
>
>
> Suchitha Koneru (sukoneru) wrote:
> >
> > What is the delivery mode for the publisher is it non persistent ?
> >
> > -----Original Message-----
> > From: teryz [mailto:teryzplace@gmail.com]
> > Sent: Wednesday, March 07, 2007 8:45 AM
> > To: users@activemq.apache.org
> > Subject: Re: [Spam: 5.0] Durable Subscription and Message Expiration
> >
> >
> > Hello there,
> >
> > Did someone observed the same problem or am i the only one?
> >
> > Help please !
> >
> >
> > teryz wrote:
> >>
> >> Hello,
> >>
> >> I am using a topic with durable subscriptions. I use
> >> apache-activemq-4.1.0-incubator.
> >>
> >> I want to limit the life of the messages my producers post in this
> > topic.
> >>
> >> It seems to me that
> >>
> >>           myProducer.setTimeToLive(10000)
> >>
> >> was the way to do it (here for ten seconds), but after any time
> >> (greater than 10secs) without any consumer reading from the topic,
> >> when launching a consumer i expect it not to find any message in the
> >> topic but it is not the case.
> >>
> >> When browsing the topic with JConsole i found that the JMSExpiration
> >> for those messages is set to a value like 1173107075408 that seems
> >> related with the JMSMessageID XXX-1173107063209-XXX and the
> >> JMSExpiration of the previous message (in this example =
> >> 1173107073695)
> >>
> >> I also tried to set time to live in the send method for my producer
> >> with the same result as described above.
> >>
> >> I saw the Jira : https://issues.apache.org/activemq/browse/AMQ-936 but
> >
> >> it is said that the problem is fixed in v4 and it is related with
> >> queues not topic.
> >>
> >> So my question is : is this a bug or is this an expected behaviour for
> >
> >> durable subscription or am i missing something here?
> >>
> >> Thanx for your help guys,
> >> Terry.
> >>
> >>
> >>
> >>
> >>
> >
> > --
> > View this message in context:
> > http://www.nabble.com/Durable-Subscription-and-Message-Expiration-tf3349
> > 488s2354.html#a9356802
> > Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> >
> >
>
> --
> View this message in context: http://www.nabble.com/Durable-Subscription-and-Message-Expiration-tf3349488s2354.html#a9370845
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message