activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From didyeah971 <didyeah...@yahoo.fr>
Subject Cannot run jetty server
Date Wed, 28 Mar 2007 09:57:23 GMT

Hi, 
I have been using the embedded jetty for a week, and now i cannot run it
anymore
I have this error : 

[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.mortbay.jetty:jetty-util:jar:6.1-SNAPSHOT

  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file -DgroupId=org.mortbay.jetty
-DartifactId=jetty-ut
il \
          -Dversion=6.1-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file

  Path to dependency:
        1) org.apache.activemq:activemq-web-demo:war:4.2-SNAPSHOT
        2) org.apache.activemq:activemq-web:jar:4.2-SNAPSHOT
        3) org.mortbay.jetty:jetty-util:jar:6.1-SNAPSHOT

----------
1 required artifact is missing.

for artifact:
  org.apache.activemq:activemq-web-demo:war:4.2-SNAPSHOT

from the specified remote repositories:
  central (http://repo1.maven.org/maven2),
  apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
  apache.incubating.releases
(http://people.apache.org/repo/m2-incubating-reposi
tory)


I tried to do what was said on the message, i downloaded the latest release
of  org.apache.activemq:activemq-web-demo:war:4.2-SNAPSHOT, and when
launching the command (quite long) 
 i have depencies issue.


Project ID: org.apache.activemq:activemq-web-demo
POM Location: C:\activemq\activemq-web-demo\pom.xml
Validation Messages:

    [0]  'dependencies.dependency.version' is missing for
org.mortbay.jetty:acti
vemq-web
    [1]  'dependencies.dependency.version' is missing for
org.mortbay.jetty:acti
vemq-core
    [2]  'dependencies.dependency.version' is missing for
org.mortbay.jetty:acti
veio-core


Reason: Failed to validate POM


I don't really wan't to modify anything i don't understand

Thx for help

-- 
View this message in context: http://www.nabble.com/Cannot-run-jetty-server-tf3478896s2354.html#a9708982
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message