activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Malathi <malathi.krrish...@gmail.com>
Subject ActiveMQ - java.lang.Exception: java.io.IOException: Could load xbean factory:java.lang.NoClassDefFoundE
Date Wed, 21 Mar 2007 15:53:05 GMT

Hi 

I have followed the Apache MQ userguide and have added the  required  jars 
to the classpath but I am still seeing the foll. error on both 4.0.2 and
4.1.0 versions when I try to run activemq.   There seems to be some kind of
class incompatibility.  Any help to resolve this is appreciated.

Description of the error message - 
Loading message broker from: xbean:activemq.xml
ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
java.io.IOException: Could
load xbean factory:java.lang.NoClassDefFoundError:
org/springframework/beans/BeansException
ERROR: java.lang.Exception: java.io.IOException: Could load xbean
factory:java.lang.NoClassDefFoundE
rror: org/springframework/beans/BeansException

jars  added to the classpath
---------------------------------
activemq-core.jar 
activeio.jar 
commons-logging.jar 
backport-util-concurrent.jar 
mx4j (if running on Java 1.4) 
j2ee.jar 
geronimo-spec-jms.jar 
geronimo-spec-jta.jar 
geronimo-spec-j2ee-management.jar 
spring.jar
apache-activemq-4.1.0-incubator.jar
spring-beans.jar


Thanks,
Malathi Krishnan
-- 
View this message in context: http://www.nabble.com/ActiveMQ---java.lang.Exception%3A-java.io.IOException%3A-Could-load-xbean-factory%3Ajava.lang.NoClassDefFoundE-tf3441677s2354.html#a9596942
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message