activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From RickardS <rickard.schou...@netgiro.com>
Subject Re: [Spam: 5.0] Large message issue with default activemq config
Date Wed, 14 Mar 2007 16:43:00 GMT

OK, I raised the usageManager increased jvm heap limit, but that only
postpones the time for block. Looking at the values presented about the
queue through JMX, the consumer seems to be up to speed and the queue is
close to 0 all the time, but "memoryPercentageUsed" is always increasing and
eventually reaches 100, and never decreases. The page you referred to says
"waiting for space to be freed up before your producer is allowed to send
more messages". Is there any other mechanism, except for consuming, that the
broker is waiting for? 

-Rickard


James.Strachan wrote:
> 
> On 3/14/07, RickardS <rickard.schoultz@netgiro.com> wrote:
>>
>> Hello,
>>
>> I tried to run the Producer and Consumer examples, but using a message
>> size
>> of 1MB (by changing the build.xml:messageSize=1000000).
>> When I run the (ant producer/ant consumer) with the default activemq
>> configuration, the producer sends 6 messages, and the consumer receives 4
>> messages. After having done that, both consumer and producer stops.
>> Debug logging in activeMQ did not reveal any problems, and the activemq
>> memory usage is around 10-20MB.
>> The activemq.xml configuration is as shipped.
>>
>> Any ideas?
> 
> http://activemq.apache.org/my-producer-blocks.html
> 
> -- 
> 
> James
> -------
> http://radio.weblogs.com/0112098/
> 
> 

-- 
View this message in context: http://www.nabble.com/Large-message-issue-with-default-activemq-config-tf3402080s2354.html#a9478429
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message