activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Arend Jansen <non...@xs4all.nl>
Subject Two brokers when embedding in Jboss
Date Sun, 11 Mar 2007 20:06:55 GMT

Hi,

I've embedded activemq 4.1.0 into jboss 4.0.5 by using the RAR. I've
modified the ra.xml to start an embedded broker. I use EJB3, like so:

@MessageDriven(
		name="jms/EventListener",
		activationConfig =
	{
		@ActivationConfigProperty(propertyName = "destinationType", propertyValue
= "javax.jms.Topic"),
		@ActivationConfigProperty(propertyName = "Destination", propertyValue =
"topic.workflow_event"),
		@ActivationConfigProperty(propertyName = "acknowledgeMode", propertyValue
= "Auto-acknowledge"),
		@ActivationConfigProperty(propertyName = "subscriptionDurability",
propertyValue = "NonDurable")
	},
	messageListenerInterface=MessageListener.class
)
@ResourceAdapter("activemq-rar-4.1.0-incubator.rar")
public class EventListenerBean implements MessageListener
{
	   public void onMessage(Message recvMsg)
	   {
	      System.out.println("----------------");
	      System.out.println("Received message");
	      System.out.println("----------------");
	   }
}

Whenever this bean is activated, a second broker (named 'localhost' seams to
be started). The activemq 'list' tool gives the following result:

ACTIVEMQ_HOME: D:\Java
BrokerName = localhost

BrokerName = embedded

Although the configuration works, it bothers me that there are two brokers
active instead of one....is this how it is supposed to be?

Cheers,
Jan Arend


-- 
View this message in context: http://www.nabble.com/Two-brokers-when-embedding-in-Jboss-tf3385705s2354.html#a9424234
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message