activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abdullah Jibaly" <amjib...@gmail.com>
Subject Re: Using activemq as a jabber server
Date Fri, 09 Mar 2007 16:23:46 GMT
Here is a screenshot showing the error I'm getting, as well as my activemq.xml:

<beans>
	<broker xmlns="http://activemq.org/config/1.0">
    <transportConnectors>
       <transportConnector name="openwire" uri="tcp://localhost:61616"
discoveryUri="multicast://default"/>
       <transportConnector name="stomp"    uri="stomp://localhost:61613"/>
       <transportConnector name="xmpp"     uri="xmpp://localhost:61222"/>
    </transportConnectors>
  </broker>
</beans>


On 3/9/07, Abdullah Jibaly <amjibaly@gmail.com> wrote:
> I forgot to mention, I also tried that simpleAuthenticationPlugin
> sample, put it in my activemq.xml but the command agent then fails to
> startup. I'm running off of the svn trunk and built activemq using
> maven.
>
> Thanks,
> Abdullah
>
> On 3/9/07, Abdullah Jibaly <amjibaly@gmail.com> wrote:
> > Hi James,
> >
> > Thanks for the response. The method you outlined is exactly what I
> > want to use it for. However, I think my question is much more basic:
> > In the xmpp page you have an example with spark, using a username and
> > password right? How do I configure a username and password is my
> > question? I tried putting in a random username and password and i get
> > back "invalid username/password"...
> >
> > Thanks,
> > Abdullah
> >
> > On 3/9/07, James Strachan <james.strachan@gmail.com> wrote:
> > > On 3/8/07, Abdullah Jibaly <amjibaly@gmail.com> wrote:
> > > > Hi all,
> > > >
> > > > I'm having trouble setting up ActiveMQ as a Jabber server. I tried to
> > > > follow the directions on the xmpp page but there are lots of holes in
> > > > it. For example, how do I configure the username/password, where do i
> > > > set those up? Has anyone been able to follow that assuming no other
> > > > knowledge of ActiveMQ? BTW, I followed the article on Infoq regarding
> > > > activemessaging so I was able to get messages getting sent just fine,
> > > > but had no luck with xmpp. Also, I had to build activemq from source
> > > > using maven because the latest 4.1 binaries do not include the xmpp
> > > > transport.
> > > >
> > > > So in summary:
> > > >
> > > > How do i setup jabber users so they can connect?
> > >
> > > Note that the XMPP support is not really meant as a fully fledged
> > > Jabber server supporting all of the various Jabber features - its more
> > > a way to be able to use your Jabber client to talk to ActiveMQ as a
> > > kinda management/operational tool
> > >
> > > The out of the box default has no security enabled, so you don't need
> > > to worry about configuring anything if you just want to get things
> > > going - just enable the xmpp transport connector in activemq.xml.
> > >
> > > If you want to enable some kinda security mechanism, see...
> > > http://activemq.apache.org/security.html
> > > --
> > >
> > > James
> > > -------
> > > http://radio.weblogs.com/0112098/
> > >
> >
>

Mime
View raw message