activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: java client program for Web Demo
Date Mon, 26 Feb 2007 09:15:00 GMT
On 2/26/07, pandi79 <pandiarajan.jeeva@wipro.com> wrote:
>
> Using ActiveMQ 4.0.2 Web demo sample. Able to send & browse the message via
> internet explorer as per the instruction provided by Apache.
>
> But my requirement to receive the message by using JMS stand alone program..
>
> The following steps I have done.
>
> 1. Sent the xml message via Html form (queue name is 'myqueue'
> 2. Able to browse the same in IE
> 3. Written jms program and connection details are
>
>         ActiveMQConnectionFactory factory = new
> ActiveMQConnectionFactory("vm://localhost");
>         ActiveMQQueue subQueue = new ActiveMQQueue("myqueue");
>
> and then tried to receive the message, but not got the posive result.
>
> Then changed the connection detaisl as follows
>
>         ActiveMQConnectionFactory factory = new
> ActiveMQConnectionFactory("tcp://localhost:61616");
>         ActiveMQQueue subQueue = new ActiveMQQueue("myqueue");
>
> Still there is no result.
>
> Does anyone have an idea about how to receive the message through my
> standalone jms program (but messaes are sending through html form given by
> Web-demo example)

The latter should work. When you look at the web console do you see a
number of messages on the queue "myqueue" ready to be consumed? Are
you running any other consumers at the time? You might want to look at
the JMX console.

This might help...
http://activemq.apache.org/i-am-not-receiving-any-messages-what-is-wrong.html
-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message