activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: 4.1 hang in ActiveMQSession.setClientID
Date Wed, 14 Feb 2007 10:21:30 GMT
The hang could just mean that the broker is down/hung/busy? Its
basically just waiting for the broker to respond. Do you see anything
in the broker log?

On 2/13/07, Jack Humphrey <jackh@google.com> wrote:
> When creating a new connection, I am sometimes seeing a hang in
> setClientID when it tries to send the info command to the broker. Has
> anyone seen this? Any ideas? Thanks.
>
> Id: 18, Name: ***, State: WAITING, Lock:
> edu.emory.mathcs.backport.java.util.concurrent.locks.CondVar@1f096d6
>  java.lang.Object.wait(Native Method)
>  java.lang.Object.wait(Unknown Source)
>  edu.emory.mathcs.backport.java.util.concurrent.locks.CondVar.await(CondVar.java:75)
>  edu.emory.mathcs.backport.java.util.concurrent.ArrayBlockingQueue.take(ArrayBlockingQueue.java:318)
>  org.apache.activemq.transport.FutureResponse.getResult(FutureResponse.java:42)
>  org.apache.activemq.transport.ResponseCorrelator.request(ResponseCorrelator.java:75)
>  org.apache.activemq.ActiveMQConnection.syncSendPacket(ActiveMQConnection.java:1171)
>  org.apache.activemq.ActiveMQConnection.ensureConnectionInfoSent(ActiveMQConnection.java:1259)
>  org.apache.activemq.ActiveMQConnection.setClientID(ActiveMQConnection.java:361)
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message