activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sandeep Chayapathi <sand...@wssource.com>
Subject slave server, transportConnectors and port 62001
Date Tue, 20 Feb 2007 19:41:08 GMT

Hi all,
 This is a question regarding setting up a master-slave activemq. The 
http://activemq.apache.org/xml-configuration.html xml configuration  shows
the following for transportConnector's

---
    <transportConnectors>
       <transportConnector name="openwire" uri="tcp://localhost:61616"
discoveryUri="multicast://default"/>
       <transportConnector name="ssl"     uri="ssl://localhost:61617"/>
       <transportConnector name="stomp"   uri="stomp://localhost:61613"/>
    </transportConnectors>
---

and the following for setting a up a pure 
http://activemq.apache.org/masterslave.html master slave :

---
<broker masterConnectorURI="tcp://masterhost:62001"
shutdownOnMasterFailure="false">
  . . . 
</broker>
---

does amq listen on port 62001 by default or should I add another
transportConnector on both master/slave ? If yes, what does the config look
like ?

Im raising this question because, with the default xml config, if I start
the slave, I see the following error in the log file:

--- 
ERROR MasterConnector                - Failed to start network 
bridge: java.net.ConnectException: Connection refused
....
----

- Sandeep
-- 
View this message in context: http://www.nabble.com/slave-server%2C-transportConnectors-and-port-62001-tf3262759s2354.html#a9068862
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message