activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GaryG <ggive...@us.ibm.com>
Subject ActiveMQ Broker dying
Date Tue, 20 Feb 2007 00:46:23 GMT

I'm having a problem with my Broker shutting down for no reason.

I'm running it with mostly default configuration from command line:

/opt/activemq-4.1.0/bin/activemq > /dev/null &

My config file sets up the broker with Derby persistence adapter.  

<broker brokerName="amqDev2" useShutdownHook="false" useJmx="true"
xmlns="http://activemq.org/config/1.0">

Here are the last few logs out of activemq.log:
-----------

2007-02-20 00:11:18,003 [eckpoint Worker] DEBUG DefaultJDBCAdapter            
- Deleted 0 old message(s).
2007-02-20 00:11:18,003 [eckpoint Worker] DEBUG JDBCPersistenceAdapter        
- Cleanup done.
2007-02-20 00:11:18,003 [eckpoint Worker] DEBUG JournalPersistenceAdapter     
- Checkpoint done.
2007-02-20 00:14:47,336 [34.186.85:58648] DEBUG UsageManager                  
- Memory usage change.  from: 19, to: 20
2007-02-20 00:16:17,991 [eckpoint Worker] DEBUG JournalPersistenceAdapter     
- Checkpoint started.
2007-02-20 00:16:18,001 [eckpoint Worker] DEBUG JournalPersistenceAdapter     
- Checkpoint done.
2007-02-20 00:18:03,432 [main           ] INFO  BrokerService                 
- ActiveMQ Message Broker (amqDev2,
ID:atla-dev-aic2.mss.iss.net-38553-1171920526058-1:0) is shutting down
2007-02-20 00:18:03,434 [main           ] INFO  NetworkConnector              
- Network Connector default-nc Stopped
----------------

Everything is working fine, messages are going across, then all of a sudden,
for no reason broker shuts down.  

This is driving me nuts, as this problem has been happening for a while now,
and I cannot figure out why.  

Any suggestion is appreciated!
-- 
View this message in context: http://www.nabble.com/ActiveMQ-Broker-dying-tf3256131s2354.html#a9052637
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message