activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From naga007 <NSo...@gmail.com>
Subject Re: Demand Forwarding Bridge issue
Date Sat, 17 Feb 2007 15:02:08 GMT


As per my understanding, if we need evenly balanced queues we should set
conduitSubscriptions=false and also it is more appropriate to set this
incase of topics. Iam not sure if iam correct, but would appreciate any
feedback on this. 




rajdavies wrote:
> 
> why is conduitSubscriptions false ?
> 
> On 17 Feb 2007, at 01:48, naga007 wrote:
> 
>>
>> I have complex application which has a producer and multiple consumers
>> consuming messages from a Queue. The application runs on two different
>> servers connects to a activeMQ broker which has demand forwarding  
>> bridge to
>> another activeMQ broker running on a different server. When running  
>> a simple
>> loadtest its seems like messages are not being forwared to the second
>> broker. Iam not sure if iam doing  anything wrong and would  
>> appreciate any
>> help from activemq folks.
>>
>> Here is my demand forrward bridge configuration.
>>
>>          <networkConnectors>
>>          <networkConnector uri="static://(tcp://remotehost:61616)"
>> failover="false" name="queues_only" dynamicOnly="true"
>> conduitSubscriptions="false" decreaseNetworkConsumerPriority="false"
>> networkTTL=99 bridgeTemporaryDestinations="true"> </networkConnector>
>>     </networkConnectors>
>>
>>
>> Also, i would like to know the criteria on which broker will start
>> forwarding messages to remote broker.
>>
>> -- 
>> View this message in context: http://www.nabble.com/Demand- 
>> Forwarding-Bridge-issue-tf3243211s2354.html#a9015804
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Demand-Forwarding-Bridge-issue-tf3243211s2354.html#a9020609
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message